WordPress.org

Ready to get started?Download WordPress

Forums

"Add Media" button stopped working- JS errors (1 post)

  1. Crabnab
    Member
    Posted 1 year ago #

    Upgraded from 3.4.1 to 3.5.1 and everything seemed to work at first, including the "Add Media" button- now, it seems to have quit functioning.

    The behavior of the button is that clicking it does nothing at all. Opening the inspector, and I get this error on click:

    Uncaught TypeError: Object function (a){return new m(a)} has no method 'omit' media-views.min.js:1
    f.controller.Library.f.controller.State.extend.initialize media-views.min.js:1
    g.Model backbone.min.js:10
    f.controller.State.Backbone.Model.extend.constructor media-views.min.js:1
    d backbone.min.js:38
    f.view.MediaFrame.Post.f.view.MediaFrame.Select.extend.createStates media-views.min.js:1
    f.view.MediaFrame.Select.f.view.MediaFrame.extend.initialize media-views.min.js:1
    f.view.MediaFrame.Post.f.view.MediaFrame.Select.extend.initialize media-views.min.js:1
    g.View backbone.min.js:33
    f.View.Backbone.View.extend.constructor media-views.min.js:1
    d backbone.min.js:38
    d backbone.min.js:38
    d backbone.min.js:38
    d backbone.min.js:38
    wp.media media-models.min.js:1
    wp.media.editor.add media-editor.min.js:1
    wp.media.editor.open media-editor.min.js:1
    (anonymous function) media-editor.min.js:1
    v.event.dispatch jquery.js:2
    o.handle.u jquery.js:2

    On the page load, however, there is another error that shows before the one above:
    GET http://site.com/wp-content/plugins/tabbed/js/ajax.js?ver=3.5.1 404 (Not Found) post-new.php:38

    NOTE: The actual URL of the site in question has been obfuscated for confidentiality- there isn't actually a GET request going to site.com :)

    Thanks in advance for any help.

Topic Closed

This topic has been closed to new replies.

About this Topic