WordPress.org

Ready to get started?Download WordPress

Forums

Frontier Post
[resolved] Add media button not working (13 posts)

  1. gbunz
    Member
    Posted 1 year ago #

    This is a FABBBBBBBBBBB widget. Loving it!

    At the moment though, the add media button isn't working and I can't seem to figure out why. I tried on chrome and safari but still not working. Help pls!

    PS - The alst frontend widget I installed erased all my posts. This one is really good. WIll give a 5 star once I figure out the whole media button thing.

    Thanks!

    http://wordpress.org/extend/plugins/frontier-post/

  2. finnj
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    What version of WP are you using

    What role are you using to test (ex. author) ?

    And what are your Frontier Post settings for that role ?

    I know there is a conflict with plugins that blocks access to wp backend (admin access) like in Theme My Login - If admin access is blocked you can not use the media upload.

    Blocking admin bar is OK.

  3. gbunz
    Member
    Posted 1 year ago #

    Hi!

    I have the latest version of WP. I used author to test as the instructions mentioned that wp wouldn't allow subscribers and contributors to upload pics.

    Frontier Post settings for author can add, edit tags, upload media, (minimal visual).

    I'd really like for everyone to be able to upload media, so I'll resort to editing the capabilities for author to be similar/same with admin. So everyone who signs in is defaulted to author (so they can upload media) but have admin capabilities. But upload media button needs to work first...

  4. finnj
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Strange, this is one of the things I test quite a lot....

    What isn't working ?
    - Can you press the media button
    - Can you insert existing media
    - When does the upload fail ?

    Can you try and test with a editor profile +

    Have you tried to clear your browser cache, first try ctrl-F5, if that doesn't help, clear the browser history and cache from the browser settings

    What other plugins have you installed ?

    You should not change the capabilities of the standard roles, you could face security issues on your blog.

    If nothing of the above is working, I have been planning to add a custom role

    Frontend Author
    into the plugin, I could speed this up, and upload a test version you could test.

  5. gbunz
    Member
    Posted 1 year ago #

    I can press the media button but nothing happens after that. I tried all of the above. I've got a couple of plugins including; comment images, dropifi, gravityforms, polldaddy, ratingwidget, related posts, shareaholic, simple pages sidebars, simply show IDs, tipsy social buttons, top commentators, ultimate tag cloud, vertical scroll recent posts/comments, wp status notifier. Those are the major ones

    Thanks for the tip. I wouldn't edit the capabilities of standard roles, but I've seen that there are plugins that'll allow subscribers and contributors to upload media...

  6. gbunz
    Member
    Posted 1 year ago #

    I can press the media button but nothing happens after that. I tried all of the above. I've got a couple of plugins including; comment images, dropifi, gravityforms, polldaddy, ratingwidget, related posts, shareaholic, simple pages sidebars, simply show IDs, tipsy social buttons, top commentators, ultimate tag cloud, vertical scroll recent posts/comments, wp status notifier. Those are the major ones

    Thanks for the tip. I wouldn't edit the capabilities of standard roles, but I've seen that there are plugins that'll allow subscribers and contributors to upload media...

  7. finnj
    Member
    Plugin Author

    Posted 1 year ago #

    I believe it must be a conflict with one of your plugins, as it is working for others.

    Have you installed or upgraded any of your plugins lately ?

    I would suspect it could be gravity forms as this plugin offer similar functionality, but I am far from sure.

    The media upload is driven by javascript and it could very well be a js conflict.

    you could try and deactivate the last plugins you installed/upgraded to see if it helps

    alternatively uninstall Frontier post, and reinstall it from the plugin directory again.

    subscribers and contributors to upload media

    I did that in the first versions my changing capabilities on the subscriber role, but since that will impact all of wordpress I removed it again.

    If I am adding one or more Frontier roles to the plugin, do you need more than one - In other words do you both need a subscriber and author type custom role ? and if so can you tell me why (trying to understand how people are using it)

  8. gbunz
    Member
    Posted 1 year ago #

    Nope I only installed upgraded Frontier Post.I also deactivated gravity forms but still not working.

    I'd like a role that only gives users access to their profile and allows them to upload media. I hope that helps!

    Thanks for all the support! Will still rate this plugin a 5.

  9. finnj
    Member
    Plugin Author

    Posted 1 year ago #

    I will give it a try :)

    Do you have a test system, where you could test it once I have figured it out.

    It is next on my list, right now I am finishing adding more editor capabilities:
    - Emotions (smileys)
    - Table control
    - Search & Replace

  10. finnj
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Uploaded a test version you can download here: v. 1.5.2

    I haven't tested it a lot, so be carefull - Should work though :)

    New in version 1.5.2
    - Control over tinymce tool bar, will only affect frontend editing
    - - Smileys (emotions)
    - - Search & Replace
    - - Table control
    - Possibility to add role (Frontend Author) from settings

    If possible please test ....

  11. gbunz
    Member
    Posted 1 year ago #

    :(

    Tried it, the Frontend Author role (very nice idea though) didn't work. Nothing happens on the page. Also, still can't upload media...

    I'll just give up for now. I really wish I could figure out what's stopping the media upload button from working...

  12. gbunz
    Member
    Posted 1 year ago #

    wait! it workedddddd! well not the media upload, that's still not working. but the frontend author role is active and allows uploads, yet admin bar doesn't show. fabulous!!

    Gosh I need this media upload to work!! I'll delete which other plugin isn't allowing it work just can't find it.

    Anyway thanks for all the support

  13. gbunz
    Member
    Posted 1 year ago #

    Update!

    SOOOO in an attempt to find the culprit plugin that wasn't allowing the upload button to work, I deactivated all plugins and re-activated in groups. Unfortunately I can't pin-point the culprit plugin but it's all now working! Now it's working!!! lol thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic