WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Add Media button is not working (12 posts)

  1. kayrich
    Member
    Posted 1 year ago #

    Hello,

    My add media button is not working when I try to add media to my posts (very frustrating). I click it and nothing happens. I have tried Safari, Firefox, and Chrome. Apparently a lot of people are having this problem with the newest version of wordpress. Is there a fix for this yet?

  2. esmi
    Forum Moderator
    Posted 1 year ago #

  3. kayrich
    Member
    Posted 1 year ago #

    I have tried everything here. I have no plugins active and cleared my cashe. Same problem.

    Doing my own research I found out this was thr problem with the 'add media button in 3.5

    "The error means that WordPress 3.5 combines all the scripts into one script loads them using load-scripts.php file instead of loading them separately. This certainly saves some loading time but causes multiple problems. Disabling this behavior will get rid of the error message. "

    I still don't know how to disable it with the code provided in the link below but you may find this article really helpful in correcting the problem for everyone.

    http://www.technize.net/add-media-button-not-working-wordpress/

    Please keep me updated if/when this is fixed.

    Thank you for your hard work.

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    Try adding define('CONCATENATE_SCRIPTS', false ); to the bottom of your wp-config.php file (just before the require_once line).

  5. kayrich
    Member
    Posted 1 year ago #

    the add media button still doesn't work. Any other solution, fixes? Can I download an old version of wordpress? like 3.2?

  6. JonLeeHart
    Member
    Posted 1 year ago #

    I'm having the same problem.

  7. mrkenray
    Member
    Posted 1 year ago #

    same problem - thanks, right at Christmas. Just great.
    Anyway, opened the editor in an OLD version of Opera, and got the button to load the fancy new "media interface" - text "UNDEFINNED" appearing JUST EVERYWHERE, but I did manage to get my photo in.
    This has got to be the biggest, worst, most ill-timed screw up in the history of wordpress.

  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @JonLeeHart and @mrkenray -- sorry you're having difficulties with this, understandably frustrating. But per the forum guidelines, please start your own threads and include relevant information such as the theme you are using and a link to your site. Also, you'll need to go through the troubleshooting steps in this post:

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list

  9. kayrich
    Member
    Posted 1 year ago #

    I tried everything. Even went through the toubleshooting steps. This is really hurting a lot of sites. Some are businesses. If this problem is not fixed soon will a DOWNGRADE from 3.5 be available so we can have the add media button back?

  10. I tried everything. Even went through the toubleshooting steps.

    Did you get any errors in your browser's JavaScript console? If so what were they?

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

  11. rachelreeves
    Member
    Posted 1 year ago #

    This is ridiculous. And yes, I'm having the exact same problems as everyone else so, no, no need to 'start another topic' as my problem is the same.

    Since the new 'Add Media' was added, I can't post anything as the 'Text' section doesn't work, and I can't upload photographs as the 'Add Media' button doesn't work, or add the code to add videos as I can't get into 'Text' to do it.

    WHY does WordPress always update without thoroughly testing everything?

    As it stands now, my site is at a complete standstill as I cannot do anything with it. As this is my business, I don't have the option of sitting and waiting for a 'fix'.

    If this isn't solved in 24 hours, I'll have no choice but to move all my sites to Blogger. At least they don't do ridiculous changes without testing them first. Sooooooo sick of WordPress :(

  12. Okay, while this can be therapeutic up to a point, we've well and truly left kayrich's original problem in the dust and this thread stopped being productive a while ago.

    Starting from the top:

    If you have 3.5 issues as stated review the 3.5 Master List.

    http://wordpress.org/support/topic/troubleshooting-wordpress-35-master-list

    Really do that. It may help you if you want to solve your problem. There's no magic bullet and self-hosting your own WordPress sometimes does take work. That includes reading "a three thousand word help document".

    That's not something recommended by an "Artificial Intelligence bot" that's what we unpaid volunteers recommend as an effective solution to your problem. This is a volunteer self-help community driven support forum and that requires your involvement to help us help you.

    "Help me help you" does sound very Jerry Maguire but it's true. ;)

    More specifically many of the problems are related to Javascript issues and that's why I and others recommend people check that too.

    http://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors

    That can help you find what the issue is with your installation and then you can work on solving your problem.

    WHY does WordPress always update without thoroughly testing everything?

    That's 100% not the case and this release was tested and vetted. Sorry but that's the truth.

    http://wordpress.org/news/2012/09/wordpress-3-5-beta-1/

    If this isn't solved in 24 hours, I'll have no choice but to move all my sites to Blogger.

    I'm truly sorry you feel that way. If you do go that route then I'm sure Blogger will assist you with that import into their system.

Topic Closed

This topic has been closed to new replies.

About this Topic