WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] Add Media and Featured Image buttons not working (18 posts)

  1. daverage
    Member
    Posted 1 year ago #

    When I create a new post, clicking the Add Media button and the Featured image button, don't seem to do anything at all?

    I am using 3.5-RC2-22928.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Both Add Media and Set Featured image are working on new Posts for me using WordPress 3.5-RC2-22928.

  3. daverage
    Member
    Posted 1 year ago #

    Seems to just be the images dialogue that wont popup. Was fine on 3,42

  4. Cache cleared? Any errors in the browser error log? Which browser/OS?

  5. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress 3.5-2-22928.. Make sure that you delete the old copies of files & folder before uploading the new ones. Also try deactivating all plugins and switching to Twenty Twelve theme.

  6. daverage
    Member
    Posted 1 year ago #

    Ok, gets a little strange now. I ran it from home and it works. Run it from work and I get the following

    Uncaught TypeError: Cannot call method 'replace' of undefined load-scripts.php:407

    The comes from // Underscore.js 1.4.1

    The only thing that has changed of late (a big thing) is the fact I am now using w3 total cache to host files on a CDN subdomain.

    So, I removed the JS files from the CDN and at work, still the same problem. Is there something new that is doing some kind of cross domain call from javascript?

    However, not sure why this would work from home and not at work - any help would be very appreciated!!

  7. So, I removed the JS files from the CDN and at work, still the same problem. Is there something new that is doing some kind of cross domain call from javascript?

    Did you flush cache and/or try a different browser?

    What's different between home and work? Browser? OS?

  8. _Redd
    Member
    Posted 1 year ago #

    Hi, I also have been having consistent trouble with the featured image, in both 3.5-RC1-22909 (multisite) and 3.5-RC2-22995 (multisite).

    In both cases, the browsers used were Chrome 23.0.1271.95 m and Firefox 10.0.2.

    The featured image never displays in the post itself for RC1 and RC2, although I was able to make it display in the post in earlier beta releases.

    In 3.5-RC1-22909, One of the test pages may be seen here:
    http://red-hound.com/wpbeta3rc1/wordpress/image-test-one/image-test-three/

    When RC2 came out, I created a fresh install,and revisted uploading featured images. The uploader displays the image, but will not display in post.

    An example may be seen here:
    http://red-hound.com/wordpress35rc2/wordpress/featured-image-test/

    In all cases, the uploader will show me the image, and allow me to choose it. In some cases, the selected image will show up in the featured image metabox, in others, it will not. I haven't figured out the "pattern" behind why it will sometimes show up in the featured image metabox area, and sometimes not. In all cases, it never shows up in the post itself for RC1 or RC2. I had earlier success with the featured image showing up in the post with earler beta versions (3.5-beta-1).

    Example shown here:
    http://red-hound.com/testfor3point5c/?page_id=2

    All three examples were new installs, all were set up as multisite, and all were done on same browser configurations.

    Thanks again for any insights you may have. And especial thanks, yet again, to the team for all the incredible work you do! You rule!

  9. _Redd
    Member
    Posted 1 year ago #

    Doh! A slap-on-the-head follow-up!

    I forgot to add, I've had no error messages display when working with any media functions. Debug is set to true in all three test sites.

    And, in the case of the second link referenced above, http://red-hound.com/wordpress35rc2/wordpress/featured-image-test/ is a valid address, but I linked it wrong. Sorry about that.

    Let me try again:
    'http://red-hound.com/wordpress35rc2/wordpress/featured-image-test/'

  10. daverage
    Member
    Posted 1 year ago #

    I think it is a work firewall thing. I have a feeling we block cross domain scripting in some way. Same pc, same browser through our proxy and I get the error. Turn of proxy, tether to my phone and it works first time.

    It isn't the cdn as I totally switched that off and it definitely only started after the 3.5 install :-(

  11. Oh MAN, I know I've seen that with firewalls before. If I can remember what I did to fix it, I'll come back. Gonna look.

  12. Andrew Nacin
    Lead Developer
    Posted 1 year ago #

  13. daverage
    Member
    Posted 1 year ago #

    Thanks. I have done that and refreshed caches etc. but no joy.

    I have nailed it down further. When I load the page editor (for instance) and follow the network calls in chrome, I get told the following has a bad gateway (502) However, you can go straight to it!

    http://marczewski.me.uk/wp-admin/load-styles.php?c=0&dir=ltr&load=wp-jquery-ui-dialog&ver=3.5-RC4

  14. Do you have Suhosin on your server? (Just wondering how far down that rabbit hole we should go).

    Any firewalls on your server? And if so, can you make sure your work IP is whitelisted?

  15. daverage
    Member
    Posted 1 year ago #

    No idea about suhosin. Work use a proxy with various over the top filters. As I say, 3.4.2 worked fine, just started with 3.5 :-( as soon as I am no longer in the proxy it works fine!!

  16. tinsterman
    Member
    Posted 1 year ago #

    I just upgraded to 3.5 and I am having the same problem. Featured Image dialogue is not appearing. I have cleared my cache etc.

    Any solution for this?

  17. elkirkmo
    Member
    Posted 1 year ago #

    I'm having a similar problem, but with the regular media. Featured images load and appear correctly but when I click "insert into post" on the regular "Add Media" button nothing happens. I've had to just copy the image link and put it in an img tag. I've already tried reinstalling the wp files too.

  18. esmi
    Forum Moderator
    Posted 1 year ago #

    WordPress 3.5 is not longer in beta. Please post your own topics.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.