WordPress.org

Ready to get started?Download WordPress

Forums

Custom Post Type Maker
[resolved] Add icons (5 posts)

  1. Zeno
    Member
    Posted 1 year ago #

    Hey Jorn,

    Great plugin. It just needs a bit of refinement. It stands out from all the others because of the super clean UI.

    I'm was really sick and tired of writing my own custom posts init code again and again.

    Suggestion: you might want to extend it so that you can add custom icons for the posts. This makes the interface intuitive and user friendly and is a must for my users.

    Please do keep developing it. The alternatives are terrible.

    Good job.

    http://wordpress.org/extend/plugins/custom-post-type-maker/

  2. Zeno
    Member
    Posted 1 year ago #

    One bug:
    - Tabs key doesn't work when focus is on the first field in the new custom post screen.

    One more suggestion (minor):
    - Create a custom icon for the left menu that's in the same style of the WP icons (See how Advanced Custom Fields does it).

  3. Jorn Bakhuys
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Zeno,

    Thanks a lot for the heads up. Means a lot to me.
    You understand the reason why I created this plugin in the first place, all other plugins don't have a clean UI and don't integrate well. This was the main reason to start creating my own in the hope of helping other people too.

    As NTD has already asked for full implementation of the CPT API in the other thread, I will include custom icons in the near future.

    1. Tabs: Indeed, I have experienced this and it is on my issue list. Will try to fix it
    2. Custom icon: Will add this too, to make the plugin stand out more

    Once again, thanks for the feedback, and regarding your tweet, a donation button will be included in the next version. :-)

  4. Jorn Bakhuys
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Zeno,

    Just to let you know in advance. I have worked on implementing support for icons and I am planning to release the update later today.

    Support for the icons requires WordPress 3.5 or higher at this moment, because the WordPress Media Uploader is being used.

    If you experience any problems with this, I would appreciate it if you let me know.

    Thanks!

  5. Zeno
    Member
    Posted 1 year ago #

    It's brilliant! Thanks a lot. Expect a small donation next week ;)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags