WordPress.org

Ready to get started?Download WordPress

Forums

[closed] Add existing images on server to Media Library (7 posts)

  1. suntower
    Member
    Posted 2 years ago #

    Hi,

    I have -never- been able to figure out how to add an -existing- image on the server to the Media Library and then set it as the Featured Image.

    I click on Set Featured Image, then I can always go to 'from Computer' and upload a file. Great.

    But I -thought- I should be able to go to 'From URL' and just specify an existing file already on the server. But there is no button there for 'Set Featured Image'... there is only an 'Insert Into Post' button. There's no way to add the image to the Media Library.

    What's the trick?

    ---JC

  2. psheld
    Member
    Posted 2 years ago #

    Just because an image is on the server does not mean WordPress media library 'knows' about it. You basically have to register the images with the library.

    You'll like this plugin:
    http://wordpress.org/extend/plugins/add-from-server/

  3. suntower
    Member
    Posted 2 years ago #

    I am familiar with that plug. But I thought the Set Featured Image also allowed one to link an existing image to the Media Library. Isn't that what the 'From URL' tab is for? If not, what?

    Thanks,

    ---JC

  4. alanaj7
    Member
    Posted 2 years ago #

    This plugin is going to save me a lot of time and frustration. Thank you!

    One question: should I import all the file dimensions it provides for one image?

    Thanks!

  5. Jess
    Member
    Posted 1 year ago #

    I have found that plugin to be slower than slow, and it will only process 5 images at a time, otherwise it times out and fails.

    Importing just the main image, not all of the sizes, has worked fine, just a very slow process to manually pick them out of the list 5 at a time.

    Any other suggestions for how to get images registered in the library from a folder on the server? The recent update to 3.5 lost a bunch of my uploads, so I'm dealing with a couple hundred files.

    Thank you!!

  6. mkdub
    Member
    Posted 1 year ago #

    I am having the same problem.

    I created my WP on localhost. Just tried to push the site live - imported everything with WP Importer. Checked include all media. All media was failed to be uploaded.

    As mentioned before, only images embedded into the post worked. All other media failed to upload.

    Also dealing with a couple of hundred files.

    Please help. Thanks.

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    As per the Forum Welcome, please post your own topisc. Posting in an existing topic prevents us from being able to track issues by topic. Added to which, your problems - despite any similarity in symptoms - are likely to be completely different.

Topic Closed

This topic has been closed to new replies.

About this Topic