WordPress.org

Ready to get started?Download WordPress

Forums

"Add Comment" box does not appear (15 posts)

  1. StarCapt
    Member
    Posted 4 years ago #

    I'm using Ahimsa Theme and like it very much. However, on my web site the orange "Add Comment" box does not appear upper right.
    While editing the post, it does appear in its proper place.
    Thanks for helpful replies. (Email to author not getting a response.)
    SC

  2. StarCapt
    Member
    Posted 4 years ago #

    To repeat in part: during editing, when "View Post" is selected, the orange "Add Comment" box appears in its proper place (upper right).

    But when the web site is called from one's computer,NEITHER the "Add Comment" box (upper right) NOR the "Submit Comment" (below) appear.

    I've found after calling the site that clicking on the small "No Comment" box (lower right)restores both missing boxes. But of course I want viewers to see those boxes when they post the site.

    The web site: http://SB-JustBetweenUs.com

    It's very frustrating that the theme author does not respond to queries about this.

    SC

  3. mekradendi
    Member
    Posted 4 years ago #

    first of all i would like to thanks to see it here
    it is fantastic and also great too.
    but still looking to see theme like this.
    http://shop.chipsilicon.com/

  4. rate4d
    Member
    Posted 4 years ago #

    StarCapt when writing a post or creating a page check if "Allow comments on this post" is ticked

  5. StarCapt
    Member
    Posted 4 years ago #

    In "Ahimsa Options," there is no "Allow comments on this post" box.
    In the general WordPress settings, "Allow people to post comments ..." is, and always has been, checked.

    SC

  6. StarCapt
    Member
    Posted 4 years ago #

    rate4d --

    In my previous answer, I missed the meaning of your suggestion.

    But yes, in the "Edit Post" section of WordPress while writing a post, the "Allow comments on this post" IS, and always has been, checked.

    SC

  7. mekradendi
    Member
    Posted 4 years ago #

    I have been researching WordPress Theme development lately and have discovered some invaluable resources and tutorials used to create your own WordPress Theme from the ground up.

  8. ravisarma
    Member
    Posted 4 years ago #

    StarCapt, I am the author of the theme. I haven't noticed your email to me yet since I just returned from vacation. I do see the "Add Comment" box in the single post page. Do you mean you do not see it in the home/index page? That is intentional in the design.

  9. ravisarma
    Member
    Posted 4 years ago #

    On reading your comment further, it does seem like you are talking about the main home/index page vs the single/post page. Ignore the following explication if you are aware of it: in WordPress, unless you have set your home page to be a static page, what is typically shown to your visitors is a set of 5 or so posts. The general practise, in themes, is to then allow the viewer to click on the post title, a permanent link or some other element (such as a "read more..." link, or a "Comments" link) to view the post (sometimes called a single post), with all related comments. That's the implementation in Ahimsa as well. In your case, you have only one post (I think) and you have turned off the sidebar fading, so your home page and the post page for your single post look the same -- except, as per the design, the single post page includes comments and the links for editing, commenting, etc.

  10. StarCapt
    Member
    Posted 4 years ago #

    ravisarme --

    Thanks for your reply, but I find it confusing.

    Let's see if I can explain this clearly.

    My WordPress selection allows only the most recent post to be shown. (Previous posts are available through a "Directory" page.)

    When I am editing a post and use "View Post," I see the orange "Add Comment" box in the upper right, and the text wraps around it. But when I publish that post, that upper right orange "Add Comment" box disappears and the text wraps around an empty space. There is then no "Reply" box at the bottom and no way for a viewer to make a comment. There is only a small orange "No comments" box visible at lower right. When this is clicked, the "Add Comment" box then appears at upper right and the "Reply" box appears at bottom.

    This is of course no good. I want viewers to see the "Add Comment" box at upper right with the text wrapping around it. I want this not only for practical purposes but to make the design appropriate.

    Have I made this clear?

    I like your theme and would like to continue its use, but this is a debilitating flaw.

    SC

  11. peterleando12
    Member
    Posted 4 years ago #

    If the comment box not appear in your theme then reapply the theme, i think it might work.
    Free Backlink directory

  12. StarCapt
    Member
    Posted 4 years ago #

    peterleando --

    Thanks for your suggestion. I tried downloading Ahimsa 3.0 once again, renaming the previous file "oldahimsa" and reinstalling Ahimsa.

    This does not work.

    I should add that when the theme appears, there's always a "!" in lower left corner of screen, indicating "Error on page."

    If the theme author ever appears again, the site is:

    http://SB-JustBetweenUs.com

    SC

  13. ravisarma
    Member
    Posted 4 years ago #

    See continuation of thread here:

    http://wordpress.org/support/topic/342189

  14. ravisarma
    Member
    Posted 4 years ago #

    StarCapt, just to be clear: when you say you view the post after publishing it, what is the URL at which you view the post? Is this URL the top level URL for your blog or the individual URL for that particular post?

  15. kevinsmith880
    Member
    Posted 4 years ago #

    Hi,
    Nice work, thanks again for sharing such an informative ideas.

    buffalo coins gold

Topic Closed

This topic has been closed to new replies.

About this Topic