WordPress.org

Ready to get started?Download WordPress

Forums

Add category problem (14 posts)

  1. Luca
    Member
    Posted 3 years ago #

    Hi!
    I am Italian boy and i don't know english well.
    sorry.
    i have a problem: this problem is in all my wordpress installation
    (3.0.1, 3.0.2, ...)
    what do I do?
    - enter in wordpress
    - categories
    - I want new category
    - compile the fields
    - click on add categoy

    the category does not appear in right screen.
    if I refresh the page, the category appear in the right screen.
    I've got this problem in many wordpress.

    Why?

    THX

  2. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    Hi Luca. Just to clarify. You mean since you installed WP from version 3.0.1 to current 3.1, you have to refresh the Post New or Post Edit panel in order for Category box to show up?

    To see if category box shows up in Post New or Post Edit panel without needing to refresh the page, have you:
    - deactivated all plugins?
    - change to default twentyten theme?

  3. Luca
    Member
    Posted 3 years ago #

    I compile the fields of a new category (in categories page) and click to "Add new category". if I want to see my new categories in the list of categories (in the CATEGORIES PAGE), i must refresh the categories page.

  4. @mercime
    Volunteer Moderator
    Posted 3 years ago #

    Looks like its a cache issue. What cache plugin are you using?

  5. Luca
    Member
    Posted 3 years ago #

    mmm...
    how do I know...? :)

    I have these plugin into my wordpress:
    - more fields
    - contact form 7
    - redirector
    - all in seo pack
    - breadcrumb navigation xt
    - category icons
    - MapPress Easy Google Maps
    - search meter
    - TinyMCE Advanced
    and
    - WordPress Database Backup

  6. Steveorevo
    Member
    Posted 2 years ago #

    A very odd problem indeed. I had the same thing. I narrowed it down to my theme's functions.php file. The really odd thing was I created a theme from scratch that had a virtually blank functions.php. Deleting and recreating the file resolved it for me. Apparently if an odd character or even a malformed blank 'invisible' line is present, it can wreak havoc. Because the interface uses ajax, functions.php may be echo'ing something that throws it off.

  7. luca.pantano
    Member
    Posted 2 years ago #

    find it!
    in functions.php

    <?php
    if ( function_exists('register_sidebar') )
    register_sidebar(array(
    'before_widget' => '',
    'after_widget' => '',
    'before_title' => '<h4>',
    'after_title' => '</h4>',
    ));
    ?>

    why??

  8. Steveorevo
    Member
    Posted 2 years ago #

    You have a comma (,) on your last parameter, it should be:

    <?php
    if ( function_exists('register_sidebar') )
    register_sidebar(array(
    'before_widget' => '',
    'after_widget' => '',
    'before_title' => '<h4>',
    'after_title' => '</h4>'
    ));
    ?>
  9. ronthai
    Member
    Posted 2 years ago #

    I have the same problem, new categories only show after a refresh.
    Not really a problem, but not the way it should be.
    I have nothing like the above in my functions.php
    Any more idea's suggestions

    Thanks, Ron

  10. Steveorevo
    Member
    Posted 2 years ago #

    Activate the default theme, see if it still happens. If so, there is possibly a permissions issue. If not, go back to your original theme and recreate your functions.php (try eliminating it first, note: your theme may break temporarily but check the functionality in categories first).

  11. Steveorevo
    Member
    Posted 2 years ago #

    Before checking permissions though with the default theme, check plugins (deactivate each one).

  12. aleem
    Member
    Posted 2 years ago #

    gfgdgdgd

  13. aleem
    Member
    Posted 2 years ago #

    hi i dont know wordpress use plugins plese help me

  14. Steveorevo
    Member
    Posted 2 years ago #

Topic Closed

This topic has been closed to new replies.

About this Topic