WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Add an image / add media icons not there (17 posts)

  1. zzillezz
    Member
    Posted 5 years ago #

    I'm running WordPress 2.7 beta 3, and when I want to make a new post, I see the write box. The problem is, I don't see any icons for Add an image, Add media and such above the writebox. If I click on 'Toggle fullscreen mode' I see the icons, but they're greyed out. I had the same problem with previous betas of 2.7.

    http://www.zzillezz.net/wpscreen1.png
    http://www.zzillezz.net/wpscreen2.png

    Any an idea to solve this? Thanks

  2. zzillezz
    Member
    Posted 5 years ago #

    No one has the same problem?

  3. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    It seems you have disabled JavaScript. The uploader needs it to be able to work.

  4. zzillezz
    Member
    Posted 5 years ago #

    No, I've tried accessing it from three different computers, using different browsers, it's the same on all three.

  5. Andrew Ozz
    WordPress Dev
    Posted 5 years ago #

    Perhaps update to the latest version, clear browser's cache and try again. Also check for js errors and disable any active plugins. From the first screenshot it seems that some of the js is not running properly.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Older plugins can break stuff on that screen too. Disable all your plugins, clear the cache, refresh the page. See if they come back. If so, find out what plugin is breaking things.

  7. zzillezz
    Member
    Posted 5 years ago #

    I deactivated all plugins and cleared the browser cache, still the same problem ...

    I'm using the latest version I think (2.7 beta 3)

  8. Try turning off the Rich Text Editor?

    Also what browser is that? Obviously Firefox but which version? Does it work on a different Browser? You may have something wild set on your browser.

  9. zzillezz
    Member
    Posted 5 years ago #

    It's the same with Firefox, IE, Opera.

    How do I turn off the rich text editor?

  10. zzillezz
    Member
    Posted 5 years ago #

    On this blogpost:
    http://wordpress.org/development/2008/11/wordpress-27-beta-3/

    There is a line that reads:

    " Media upload buttons won’t show if the user doesn’t have the upload capability. "

    But I'm the only user, and admin of my WordPress install.

  11. Turning off RTE, go to /wp-admin/profile.php and check 'Disable the visual editor when writing'

    Check the permissions on the uploads folder. If you go to /wp-admin/options-misc.php you can see what folder it thinks it's going to.

  12. zzillezz
    Member
    Posted 5 years ago #

    turning off the Rich Text Editor does nothing, the permissions on the uploads folder are correct. Remember, I can upload files correctly through /wp-admin/media-new.php. I just don't see the icons above the write box. In full screen mode, I see the icons, but they're greyed out. So I can't insert anything into a post.

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    When you go to the write page, do you get any errors in the Error Console?

    Those image links live or die by Javascript. Somehow, your javascript is broken on your site. Until you find where and why, they will never appear.

  14. zzillezz
    Member
    Posted 5 years ago #

    These are the error I get in the Firefox Error Console when I open the write page:

    http://www.zzillezz.net/wperrors.png

    They all have to do with jQuery

    Thanks

  15. Samuel Wood (Otto)
    Tech Ninja
    Posted 5 years ago #

    Your site is missing the jquery files.

    http://www.zzillezz.net/wp-includes/js/jquery/jquery.js gives a 404 error. It should give the jquery javascript instead.

    Reupload the WordPress files to your site, and be certain that you upload ALL the files. If the first upload missed those files, others may have been missed as well.

  16. zzillezz
    Member
    Posted 5 years ago #

    Thanks Otto42, that solved the problem.
    I don't know why the files weren't there. Two files were missing from the jquery folder. I uploaded those two files, and everything works!

    On the dashboard, the WordPress development blog and WordPress news also load now.

    Thanks for the help!

  17. corentin
    Member
    Posted 5 years ago #

    I had the same problem.

    I don't know why but every time I uploaded WordPress 2.7, some directories (the ones in wp-includes/../) were not uploaded. Maybe something with Filezilla?

    After uploading the all directories manually..... It finally works.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.