WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] add a logo (11 posts)

  1. gray919
    Member
    Posted 5 years ago #

    Hey, does anyone know which file I would edit to add a logo to the template I have?

    http://www.thehateblog.net

    And say the logo was in public_html/theme/image/logo.gif

    How would i call that in? would i use img src=' ' and put it in between <head> tags? Kinda lost here.

    thanks for the help.

  2. homerm06
    Member
    Posted 5 years ago #

    Go to /wp-content/themes/i-feel-dirty/img/headerbg.gif via your FTP client. Upload the new one and name it "headerbg.gif"

    If you wanna go the long way around, you gotta know where the html code for the original image "headerbg.gif" is and replace "headerbg.gif" to "logo.gif"

  3. homerm06
    Member
    Posted 5 years ago #

    But I'd just backup and delete the original "headerbg.gif" and upload the new logo and just name it "headerbg.gif" It's easier :)

  4. gray919
    Member
    Posted 5 years ago #

    yea i backed it up and deleted it. for some reason the size of the new header is bigger than the original one even though all I did was paste the logo on the original headerbg.gif. Anyways, i will fix that tomorrow.

    last, do you know how I cna delete the text link title of my blog? Is it something in header.php?

    thanks again for the help.

  5. homerm06
    Member
    Posted 5 years ago #

    Yeah the logo just needs to be cut down a bit from the left side.

    As for the text, it should be in the "header.php" inside your theme folder. I haven't really messed with that part so before any editing, download the original header.php file for backup.

    Good luck and post if it worked out :)

  6. gray919
    Member
    Posted 5 years ago #

    Here's my header. I thought if I removed "head1" div class, it would go away, but it didn't. Maybe i did something wrong. . . Anyways, thank you so much for the help.

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">
    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
    <title><?php bloginfo('name'); ?> <?php if ( is_single() ) { ?> &raquo; Blog Archive <?php } ?> <?php wp_title( ' ' ); ?></title>
    
    <script src="http://www.thehateblog.net/wp-includes/js/font-text-resizer.js" type="text/javascript"></script>
    
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->
    
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_head(); ?>
    </head>
    <body>
    
    <div class="cnt">
    	<div class="header">
    		<div class="head1">
    			<h1><a href="<?php echo get_settings('home'); ?>/"><?php bloginfo('name'); ?></a></h1>
    			<div class="description"><?php bloginfo('description'); ?></div>
    		</div>
    		<div class="head2">
    			<h3>About</h3>
    			<p>I tell it like it is.</p>
    		</div>
    	</div>
  7. homerm06
    Member
    Posted 5 years ago #

    Backup your header.php file replace what I show below.

    From:
    <title><?php bloginfo('name'); ?>

    To:
    <title><?php bloginfo(''); ?>

    I think that's what you're talking about. But that's why it's best to do a backup :)

    You can also try experimenting and remove the entire "div class="head1" But I haven't done that one before.

    One thing I've learned with CSS and PHP is that experimenting, messing up, and fixing it makes you learn something new :)

    Good luck!

  8. gray919
    Member
    Posted 5 years ago #

    hmm. I removed the div class head 1 and edited what you told me too and still it wont go away. But I have been having issues with my cache and what not so it might have actually gone away and I wouldn't know.

    This is my new header.php

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" dir="ltr">
    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
    
    <title><?php bloginfo(' '); ?> <?php if ( is_single() ) { ?> &raquo; Blog Archive <?php } ?> <?php wp_title( ' ' ); ?></title>
    
    <script src="http://www.thehateblog.net/wp-includes/js/font-text-resizer.js" type="text/javascript"></script>
    
    <meta name="generator" content="WordPress <?php bloginfo('version'); ?>" /> <!-- leave this for stats -->
    
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="<?php bloginfo('name'); ?> RSS Feed" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <?php wp_head(); ?>
    </head>
    <body>
    
    <div class="cnt">
    	<div class="header">
    
    		<div class="head2">
    			<h3>About</h3>
    			<p>I tell it like it is.</p>
    		</div>
    	</div>
  9. gray919
    Member
    Posted 5 years ago #

    nevermind. I think I got it working now.

    thanks for all your help.

  10. homerm06
    Member
    Posted 5 years ago #

    Ok, don't forget to resolve this post if it's all resolved :)

  11. kosngo
    Member
    Posted 5 years ago #

    I'm agree
    kos

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.