WordPress.org

Ready to get started?Download WordPress

Forums

MailPoet Newsletters
[resolved] Activation fails (4 posts)

  1. 14nc310t
    Member
    Posted 1 year ago #

    After the installation, trying to activate the plugin the system hang.

    From that point I cannot no more acces wp-admin funcionality like Dashbooard etc...

    Manually removing the installation directory in wp-content/plugins, resolve the problem

    Following are my server parameters:

    Operating System : Linux (64 Bit)
        Server : Apache/2.4.3 (Unix) mod_fcgid/2.3.7
        Memory usage : 61.89 MByte
        MYSQL Version : 5.0.92-enterprise-gpl-log
        SQL Mode : Not set
        PHP Version : 5.2.17
        PHP Safe Mode : Off
        PHP Allow URL fopen : On
        PHP Memory Limit : 64
        PHP Max Upload Size : 25M
        PHP Max Post Size : 30M
        PCRE Backtracking Limit : 500000
        PHP Max Script Execute Time : 120s
        PHP Exif support : Yes ( V1.4 )
        PHP IPTC support : Yes
        PHP XML support : Yes

    Any idea how to fix this??
    TIA

    http://wordpress.org/extend/plugins/wysija-newsletters/

  2. foaad
    Member
    Posted 1 year ago #

    I almost have the same issue. The plugin was installed before. All of the sudden WP could not see the plugin and it was asking to be re-installed. The installation constantly fails whether using direct "add new", upload, or uploading the unzipped folder into the plugin directory. Any ideas?

  3. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Well this error happens in a minority of server configuration.
    I think it is link to the size of our package which gets heavier with time, with added translations and code.

    We're planning to force our plugin to do a veggie diet at some point, we're just not sure when.

    As for now the only solution I found is to install the plugin through FTP if that happens, otherwise you can also try to increase your server's configuration, maybe try to increase the memory_limit or upload_max_filesize of your php server.

    Cheers,
    Ben

  4. Ben
    Member
    Plugin Author

    Posted 1 year ago #

    Actually here is an update, I now believe this is due to the value of the max_execution_time parameter in PHP . When the execution time passes that value, your server returns a fatal eror putting a stop to the process wherever you are in the script.

    To put it simply this seems to be one problem that we don't have control over. Our guess is that our increasing package size and the number of files we have in our plugin are the responsible here, but we've no proof of it yet.
    The issue happens when WordPress is installing the plugin, this is how it happens I believe :

    1. WordPress deactivates the previous version of wysija
    2. WordPress deletes the old plugin folder
    3. WordPress download the new plugin
    4. WordPress unzip the new plugin in a temporary folder
    5. WordPress moves the files one by one to the destination folder plugins/wysija-newsletters

    And here is the problem, during that last step at some point the script fails, and we think this maybe because the update request took too long to be processed, and that's based on your server's settings.

    That's the main reason I can think of :

    • max_execution_time is too low
    • The bandwidth on your server is not so high so it took time to download our 2.5Mb plugin
    • We have too many files in our plugin and it takes time for WordPress to move them one by one to the destination folder.

    Now at that stage, you find yourself with a wysija-newsletters folder which is half empty and not recognized by WordPress as a valid plugin. So when you try to install the plugin again, WordPress will tell you that the folder wysija-newsletters already exists while it won't appear in your plugin's listing.

    So anyway for now the solution remains the same, delete the folder using FTP and install the plugin again.

    Now if my theory is right, technically this problem would happen with other plugins, try for instance with this heavy plugin :
    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

    Install an old version for instance that one : http://downloads.wordpress.org/plugin/all-in-one-event-calendar.1.8.2.zip
    And then try to update it to the latest version, I guess a similar issue should happen on your server. Maybe the process will fail even earlier.

    Let me know,

    Ben

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.