WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Activate pending users (10 posts)

  1. Heyryck
    Member
    Posted 2 years ago #

    Hi everybody,

    I have a multisite install with 3 sites. I've tried to register some users and althouth it says

    But, before you can start using your new username, you must activate it.

    if I check under Users Menu I can't see any pending users, I have also tried to install New User Approve plugin but I can't see any users.

    How can I activate manullay users?

    Thanks

  2. They have to click on the email that was sent when you registered them.

    Do the users exist on /wp-admin/network/users.php

  3. Heyryck
    Member
    Posted 2 years ago #

    No, on /wp-admin/network/users.php appears only admin - Super Admin

    I didn't specify that I've installed wpmu locally with easyphp 5.3.9

  4. If you add a user from /wp-admin/network/user-new.php they get emailed their password and have to click okay to be added.

    If you do it from /wp-admin/user-new.php (i.e. the add user from the site), you can just add them as is.

    I don't know why it's that different, to be honest...

    Anyway. You were using this plugin? http://wordpress.org/extend/plugins/new-user-approve/ That one lets you approve all users who try to register.

    You want something like http://wordpress.org/extend/plugins/user-activation-keys/

  5. Heyryck
    Member
    Posted 2 years ago #

    Yes I have installed new-user-approve and if I click on the "Approve New User" link in the Users menu there is no user under the "Users Pendig Approval"

    With user-activation-keys I was able to approve user pending.

    I don't undertand why with this plugin I can and with "new-user-approve" no.
    Anyway I approved the user but if i try to log in wordpress says that account is still pending approval.

    what a mess.. :)

  6. Becuase you misunderstood what 'approve new user' meant :) It means 'When someone signs up, I have to approve their account.' and their accounts won't show up until after they activate it. Basically it's a double-activation.

    Do you have both plugins installed now?

  7. Heyryck
    Member
    Posted 2 years ago #

    You're right, I don't understand.. :)

    Now I have both plugins installed, but although I have activated an account, I can't see it until that user activates his aoocunt by email??

    So there are 2 possibilities to create an account. The first is the admin that adds manually an account and in this case this account is active and ready to use

    The second possibility is a user that sign up from the site, but though tha admin actives this account, it isn't active until the user activates it with the link sent via mail

    correct? If so I confirm.....what a mess :)

    Thanks

  8. If you have both plugins, here's what happens when someone signs up to your site:

    1. Enter in desired ID and email address, which sends an email.
    2. Click on the 'activate' link in the email.
    3. SuperAdmin (you) sees the user on the 'User Registration Approval' page and clicks 'approve.'
    4. Done.

    Does that make sense?

  9. Heyryck
    Member
    Posted 2 years ago #

    yes it make sense.
    So if a user lost activation mail, the superAdmin can't do anything and the user must wait 2 days and try to register again!?

    we can say that whith this plugin superAdmin can control user activation and eventually reject

    However thanks a lot, I change the topic to resolved

  10. Yeah, the 'lost registration' thing is a hassle. :/ YOu can clear it out of the DB directly, but I don't know a good plugin for it yet.

Topic Closed

This topic has been closed to new replies.

About this Topic