WordPress.org

Ready to get started?Download WordPress

Forums

BadgeOS Community Add-on
[resolved] Achievements Tab Not Visible on Admin Profiles (11 posts)

  1. xr4v3nx
    Member
    Posted 9 months ago #

    Not sure if it's just me but the Achievements tab doesn't show up on Admin accounts/profiles.

    The recent update fixed the missing Achievements tab (bravo!) except for admins.

    http://wordpress.org/plugins/badgeos-community-add-on/

  2. Michael Beckwith
    Member
    Plugin Author

    Posted 9 months ago #

    Just as a check, does your admin account(s) have any achievements earned? I recall a moment in internal chat, that the tab is only going to show up if the user has earned any achievements. If you could check and confirm that if your admin account has any achievements, it still disappears, or if it shows up finally, that'd help us out.

  3. xr4v3nx
    Member
    Posted 9 months ago #

    Hello! Yes, my main admin and other test admin accounts have achievements earned. I also tried disabling all plugins except BuddyPress, BadgeOS and Community add-on.

  4. Michael Beckwith
    Member
    Plugin Author

    Posted 9 months ago #

    Any changes with this, or do you need us to investigate it more? Sorry for the late reply

  5. xr4v3nx
    Member
    Posted 9 months ago #

    Actually, after more testing, I noticed that whoever has an achievement (both admins and non-admins), loses the achievements tab. If a user has no achievement at all, the tab is visible (when clicked, it obviously shows the 'No completed to display at this time.' message). If a user has at least an achievement, s/he loses the achievements tab.

    It's completely reversed. This is so weird.

    Also, under the Activity, only admins who receive achievements gets announced but not regular users.

  6. Michael Beckwith
    Member
    Plugin Author

    Posted 9 months ago #

    Hmm, I'll report this finding to our GitHub issues for this topic, as I know there was some changes done in BadgeOS 1.3 that affected this topic.

    You can see the previously reported issues at https://github.com/opencredit/BadgeOS-Community-Add-on/issues/9

  7. xr4v3nx
    Member
    Posted 9 months ago #

    Thank you Michael.

  8. orlandowae
    Member
    Posted 8 months ago #

    Following... Same here. Mine disappears for anyone who's earned an achievement.

  9. ls41
    Member
    Posted 8 months ago #

    Would like to see this fixed.

  10. xr4v3nx
    Member
    Posted 8 months ago #

    I'm glad I am not the only one experiencing this. Thanks for reporting!

  11. Michael Beckwith
    Member
    Plugin Author

    Posted 8 months ago #

    Yeah, the problem is that I can't see any consistent patterns yet, which = frustration.

    I know that you need an earned achievement for it to show up. Steps don't count.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.