WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Accidental upgrade to wp 3.1beta (6 posts)

  1. Zenec
    Member
    Posted 3 years ago #

    Hi

    I've been using a wordpress localisation for quite a while already. A while ago, I noticed that the version offered on the upgrade page didn't really make sense as it was offereing me to "upgrade" to a lower version of wordpress. Nevertheless, pressing upgrade upgraded my wordpress to 3.0.1 (I think, not sure), just as I wanted. Now just today, I saw somewhere on the web that 3.0.3 is out and though - oh, I should upgrade my blog. This time the upgrade button said "You are about to install WordPress 3.0.3 in English (US). There is a chance this update will break your translation. You may prefer to wait for the localized version to be released.". I didn't mind that so I just upgraded.

    But turns out, the upgrade downloaded wordpress from nightly builds and now I am using 3.1-beta1-16732. Some plugins are not working that great with the new version, so I was wondering:

    1.How do I downgrade to 3.0.3? I could use the backup I made before upgrading, however, that would lead me back to the slightly faulty previous installation that led me to this in the first place.

    2.How do I make wordpress stick to the stable releases?

    Please, do not offer me to delete everything and start all over again. Can I somehow just replace some (most) files and edit some database entries?

    Thanks!

  2. demetris
    Member
    Posted 3 years ago #

    To start with your second question:

    WordPress shouldn’t be offering updates to beta versions unless you use a plugin specifically for that, like WordPress Beta Tester:

    http://wordpress.org/extend/plugins/wordpress-beta-tester/

    Do you have any plugin like that installed?

    Now to your first question:

    You can downgrade to 3.0 and most likely everything will work fine, but you have to do it manually and very carefully:

    First, delete the wp-admin and wp-includes directories.

    Then delete all WordPress files from your root directory. Be carefull, of course, not to delete files that are specific to your installation like wp-config.php and .htaccess.

    Then upload via FTP the 3.0 files.

  3. demetris
    Member
    Posted 3 years ago #

    See also the Codex, which has a detailed article on updating with a section on manually updating:

    http://codex.wordpress.org/Updating_WordPress

  4. Zenec
    Member
    Posted 3 years ago #

    Hi

    Thanks for your answer. What I actually just did (and it worked fine) is:
    1.Used backup to get back to the version that brought me to the issue the first place.
    2.Downloaded wordpress 3.0.3 and extracted the files over the one's I've got, in a sense, risking it and doing a quick and dirty version of steps 7 and 8 from here: http://codex.wordpress.org/Upgrading_WordPress_Extended
    3.I didn't make any changes to the database.

    Now I've got 3.0.3 installed and no upgrades are offered. Let's hope that when 3.0.4 comes out, I will be offered an upgrade and that it will actually upgrade to 3.0.4 ;)

    To answer your question - no, I don't have any beta tester plugins installed. I blame it on the localisation I had installed beforehand. Do you know how does wordpress determine, whether to upgrade to stable or beta version? Is it a database entry?

    Thanks for your advice, though. I will mark this thread as solved.

  5. Mark Jaquith
    WordPress Lead Dev
    Posted 3 years ago #

    Zenec — which localization were you using?

  6. Guilherme Euler
    Member
    Posted 3 years ago #

    The same thing happened to me. My WordPress had a message to update, but there's no updates do my language (pt-BR) so I updated to english but for my surprise, my WordPress comes to beta version 3.1.

    I solved the problem, but it's an alert. Some thing is wrong with new updates to new version in another language. (not the blog original language)

    For annotation: I solved the problem deleting the core files and uploading the files of 3.0.3 version to my server.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags