WordPress.org

Ready to get started?Download WordPress

Forums

JSL3 Facebook Wall Feed
[resolved] Access token expires (7 posts)

  1. muscled1
    Member
    Posted 1 year ago #

    I just installed your plugin on my site and today is February 3 2013 and it says my token expires on February 4 2013. Why does it expire in one day?

    http://wordpress.org/extend/plugins/jsl3-facebook-wall-feed/

  2. Takanudo
    Member
    Plugin Author

    Posted 1 year ago #

    Facebook should have given you a 60 day token. I'm not sure why you only got one that lasts one day. You may want to try creating a new Facebook App for the plugin.

  3. jbmeulen
    Member
    Posted 1 year ago #

    I have the same problem. It will only renew for one day.

  4. Takanudo
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried creating a new Facebook App?

  5. stormrider
    Member
    Posted 1 year ago #

    I'm getting this same problem. I created a new Facebook App a few months ago the first time I got this error. I really don't want to have to create a new app every time this app expires.

  6. Takanudo
    Member
    Plugin Author

    Posted 1 year ago #

    Try waiting 24 hours after the last time you clicked "Saved Changes" and then try again. Hopefully, Facebook will give you a 60 day token. There's not much more I can recommend beyond that. I can understand that creating a new Facebook App would be annoying. I'm not sure why Facebook does this to some people.

  7. Takanudo
    Member
    Plugin Author

    Posted 1 year ago #

    Try this, if you are up for it:

    1. Log into you Facebook page.
    2. Go to your Account Settings.
    3. Click "Apps" on the left menu.
    4. Under "Apps you use," click "Edit" for the app you created for this plugin.
    5. Under "This app can also:" remove the "Access your data any time" if it is there.
    6. Open '/wp-content/plugins/jsl3-facebook-wall-feed/php/class-jsl3-facebook-wall-feed.php'
    7. Line 823 is the following:
      "scope=read_stream,offline_access,manage_pages,user_status&" .
    8. Change it to the following:
      "scope=read_stream,manage_pages,user_status&" .
    9. Save the file.
    10. Wait 24 hours from the last time you clicked "Save Changes" on the settings page for the plugin on your WordPress site, then try again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic