WordPress.org

Ready to get started?Download WordPress

Forums

WP e-Commerce - Store Toolkit
[resolved] Access Denied (4 posts)

  1. stevemadit
    Member
    Posted 1 year ago #

    Hi There,

    I did see that there is already a thread for this issue. However the thread has been marked as resolved.

    When I go to the plugins page in wordpress and try to either go to the 'settings' page or the 'manage' page, I get the error "You do not have sufficient permissions to access this page."

    In the previous thread it mentioned that there was an issue with the links to the pages and that an update had been made to update them. However I still have the issue and i have the most up to date version of the plugin. Below i've provided the links that are currently in place for the 'settings' and 'manage' pages.

    link to settings page:
    http://www.mysite.com/wp-admin/options-general.php?page=wpsc_st

    link to manage page:
    http://www.mysite.com/wp-admin/edit.php?post_type=wpsc-product&page=wpsc_st-toolkit

    Plugin Version 1.9.2
    WordPress version 3.5.1

    http://wordpress.org/extend/plugins/wp-e-commerce-store-toolkit/

  2. stevemadit
    Member
    Posted 1 year ago #

    Hi again.

    I may have found the issue, but i'm not sure how I can rectify it. As you can see in the screenshot linked below, I have version 4.0-dev of wp e-commerce, yet the latest release is Version 3.8.9.5.

    http://www.gadgetloft.co.uk/wp-content/uploads/image123/wp-e-commerce-v4.jpg

    Additionally, I was going to export all of the data from the wp e-commerce store and install the current version 3.8.9.5. However, the 'WP e-Commerce - Store Exporter' plugin will not work either with the same error "You do not have sufficient permissions to access this page.".

    Any help or ideas would be greatly appreciated.

    - Also, just out of curiosity, how did I manage to get version 4.0-dev.

  3. Visser Labs
    Member
    Plugin Author

    Posted 1 year ago #

    Not sure how you managed to keep v4.0-dev (someone's made a mistake).

    Those links you provided were correct, we do some capability validation but this is nothing that any other Plugin does. I'm concerned that your v4.0-dev WP e-Commerce may be causing other issues with your store.

  4. stevemadit
    Member
    Posted 1 year ago #

    I did manage to delete v4.0 and manually upload the current version through ftp, without any problems and all works fine now.

    Thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic