WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
[resolved] Access Control is Broken (32 posts)

  1. Cristina
    Member
    Posted 6 months ago #

    Updated to the latest version of the plugin (after dealing with the beta versions) and now it's all broken. I can't make any changes. Below is the screenshot of when I go to Access Control:

    http://i42.tinypic.com/2d0f7ds.png

    Tried uninstalling the plugin and installing it again, and it's still the above screenshot.

    http://wordpress.org/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Cristina,
    I'm sure that you have some other plugin installed in your system that breaks it. Please deactivate all plugins and switch to default WordPress theme and find out which plugin breaks it.

    Regards,
    Vasyl

  3. Cristina
    Member
    Posted 6 months ago #

    Already did that and it didn't help.

  4. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    HI Cristina,
    Do you know if there is any JavaScript error on page? You can send me a login to your dashboard so I can check.

    Email: support@wpaam.com

    Regards,
    Vasyl

  5. pulidomate
    Member
    Posted 6 months ago #

    I have the same problem. I deactivated all plugins but the problem persists. I use aegaeus theme that incorporates default plugins like Flex slides, revolution slider..

  6. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi pulidomate,
    Please try to switch to WordPress default theme like Twenty Thirteen.

    Regards,
    Vasyl

  7. MulderCF
    Member
    Posted 6 months ago #

    Hi Vasyl,
    I have been using your plugin for a few weeks now, and all was perfect. However, since the upgrade to 2.1.1 the AAM interface on the Admin site does not list any roles or users (it seems the same issue as listed above).

    I am running on a standard Twenty Thirteen template, have tried disabling all the other plugins one by one, but the issue still remains. Tried to uninstall and reinstall, but same issue occurs.

    Any help you can provide would be greatly appreciated!

    Regards,
    Coenraad

  8. pulidomate
    Member
    Posted 6 months ago #

    Vasyl, i did it but nothing.. :(

  9. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi guys,
    Can anybody send us the credentials to the admin panel to check why it is not working?

    Our email is support@wpaam.com

    Thank you.
    Vasyl

  10. MulderCF
    Member
    Posted 6 months ago #

    Hi Vasyl,
    I have just e-mailed you access details to our backend so you can have a look. Let me know if you need anything else...

    Kindest regards,
    Coenraad

  11. marshallasm
    Member
    Posted 6 months ago #

    I am having the same issue, before the upgrade everything worked fine, I have made no changes to themes or plugins but after the update I get the same error when access the control panel of AAM. The settings work fine still it is just I cannot access the control panel to make changes. I get the same screen as in the screenshot posted by Cristina.

  12. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi guys,
    Based on what I see, it does not load the JavaScript and CSS for AAM. Please make sure that you uploaded the complete plugin to your server as well as the advanced-access-manager folder have enough permission.
    Also you can contact your hosting support team to find out why AAM js and css files are not loaded.

    Please let me know the result.
    Vasyl

  13. Lisa
    Member
    Posted 6 months ago #

    Vasyl,

    What are the names of the missing javascript / CSS files? I'm sure i loaded the whole plugin and I am my host support team, so can't do much else on that front.

    -Lisa

  14. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Lisa,
    There should be main aam.js file. There are few more files. You can find them by path plugins/advanced-access-manager/media Check Source of the page and you'll that it is there. Also I believe this link is not accessible via browser.

    Regards,
    Vasyl

  15. marshallasm
    Member
    Posted 6 months ago #

    I can confirm, all the media files are on the server in the correct folders, any other ideas?

    Like I say it worked fine before the latest update?

  16. pulidomate
    Member
    Posted 6 months ago #

    Perhaps the problem could be that the links to the plugin files beginning with https.

    I mean, if i copy this link to a browser:
    https://mywebsite/wp-content/plugins/advanced-access-manager/media/js/aam.js?ver=3.6'
    i don't see anything, but with http i can see the file:
    http://mywebsite/wp-content/plugins/advanced-access-manager/media/js/aam.js

  17. marshallasm
    Member
    Posted 6 months ago #

    I can confirm I have the same issue, I get a 500 Internal Error if trying to browse to the file using https, I can access the file fine if using http?

  18. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi guys,
    Thank you. The problem was found. I have just checked in the Development version and removed admin_force_ssl check.

    Please let me know if this will work.
    If not, I'll remove the entire SSL check part.

    Regards,
    Vasyl

  19. marshallasm
    Member
    Posted 6 months ago #

    I uploaded the files you attached in your previous post and got the error Fatal error: Class 'aam_Core_ConfigPress' not found in E:\Domains\a\DOMAIN\user\htdocs\wp-content\plugins\advanced-access-manager\application\control\subject.php on line 89

  20. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi marshallasm,
    Sorry for this. I'll check it. For some reason, during checkin the configPress file was not added. I'll add it asap and will let you know about it.

    Regards,
    Vasyl

  21. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Just added missing files. Please give a try.

    Regards,
    Vasyl

  22. pulidomate
    Member
    Posted 6 months ago #

    Hi Vasyl,

    I uploaded another time but still doesn't work :(

  23. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi pulidomate,
    Good to know. Thank you.

  24. WP AAM
    Member
    Plugin Author

    Posted 6 months ago #

    Hi guys,

    We returned back the 2.0 SSL handling. So this should fix your issued.

    Regards,
    Vasyl

  25. marshallasm
    Member
    Posted 6 months ago #

    I have just uploaded the new version and it works fine now, many thanks for your help!

  26. MulderCF
    Member
    Posted 5 months ago #

    Hi Vasyl,
    Thank you for sorting it out! It is working on my side now as well...
    Regards,
    Coenraad

  27. pulidomate
    Member
    Posted 5 months ago #

    Thanks for all Vasyl!

  28. WP AAM
    Member
    Plugin Author

    Posted 5 months ago #

    Thanks you guys for your feedback. It was very helpful.

  29. CassyEdwards1958
    Member
    Posted 5 months ago #

    I downloaded and installed this plugin this morning. No other plugins are active. Using the Twenty Thirteen template.

    Advanced Access Manager brings up a page just like the one here http://i42.tinypic.com/2d0f7ds.png

  30. marshallasm
    Member
    Posted 5 months ago #

    CassyEdwards1958 download the Development version using the below link, this worked for me!

    http://downloads.wordpress.org/plugin/advanced-access-manager.zip

Reply »

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.