WordPress.org

Ready to get started?Download WordPress

Forums

UK Cookie Consent
[resolved] Accept button doesn't work with W3 Total Cache (6 posts)

  1. acanofbeer
    Member
    Posted 1 year ago #

    Hi,

    Thanks for the nice plugin. I've noticed however that when W3 Total Cache is enabled, the accept button doesn't work. When cached page versions are displayed, the plugin notification bar displays too. When switching W3 Total Cache off, everything works as expected.

    Thanks in advance for looking into this.

    http://wordpress.org/extend/plugins/uk-cookie-consent/

  2. Catapult
    Member
    Plugin Author

    Posted 1 year ago #

    What version of the plug-in and WP are you using?

  3. acanofbeer
    Member
    Posted 1 year ago #

    Hi, thanks for getting in touch.

    I use:
    UK Cookie Consent - Version 1.4.2
    W3 Total Cache - Version 0.9.2.10
    WordPress - 3.5.1.

  4. Catapult
    Member
    Plugin Author

    Posted 1 year ago #

    Okay. Could you post a link to your site?

  5. acanofbeer
    Member
    Posted 1 year ago #

    I'd like to avoid posting a link to the site, also because the W3 Total Cache is switched off for the moment, to get your plugin do the job until it's fixed.

    But I was running with the following setup:
    WP Multisite installation 3.5.1
    W3 Total Cache General Settings:
    - Page Cache - disk: enhanced
    - Use late "init" - no
    - Minify - Auto, disk, Default, JSMin (default), Default
    - DB Cache - off
    - Object Cache - off
    - Browser Cache - on
    - CDN - off
    - Enable varnish cache purging - off
    - CloudFare - off
    - Monitoring - off
    - Use single network configuration file for all sites. - on
    - Verify rewrite rules - on
    - Enable file locking - off
    - Optimize disk enhanced page and minify disk caching for NFS - off

    Page Cache Settings:
    - Cache posts page - on
    - Don't cache pages for logged in users - on
    - Purge Policy - Page Cache - some of them on
    - everything else - off

    Minify Settings:
    - Rewrite URL structure - on
    - JS minify settings: - on, before <head> minify, default (blocking)
    - CSS minify settings: - enable
    - @import handling: - none
    - Filename length: - 246
    - other things - off and on default settings

    Browser Cache:
    - General Set Last-Modified header - on
    - General Enable HTTP (gzip) compression - on
    - CSS & JS Set Last-Modified header - on
    - CSS & JS Enable HTTP (gzip) compression - on
    - HTML & XML Set Last-Modified header - on
    - HTML & XML Enable HTTP (gzip) compression - on
    - Media & other files Set Last-Modified header - on
    - Media & other files Enable HTTP (gzip) compression - on
    - other things off

    All the other settings are kept in the default values.
    I hope this helps to reproduce the error!

    Thanks once more for your time.

  6. Catapult
    Member
    Plugin Author

    Posted 1 year ago #

    Okay - I can't really comment without seeing the site. You can contact me directly through catapultdesign.co.uk/contact if you prefer.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic