WordPress.org

Ready to get started?Download WordPress

Forums

Academica theme doesn't work? (5 posts)

  1. eschwartz93
    Member
    Posted 2 years ago #

    I was asked to update the website of a local school, and decided to use wordpress to do so. I was looking for a good theme to use, and I saw Academica but when I tried to use it all the pages print these error messages:

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\page.php on line 4

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\page.php on line 4

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\page.php on line 4

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\header.php on line 4

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\header.php on line 4

    Warning: Illegal string offset 'id' in C:\Documents and Settings\secretary\My Documents\Downloads\xampp\htdocs\wordpress\wp-content\themes\academica\header.php on line 4

    Why is it doing this and is there any way to fix it?

  2. mseriesco
    Member
    Posted 1 year ago #

    I also had similar problem few days back. All other things on website were fine. I was getting those errors. The problem was in php.ini file. But doing little change in php.ini file worked for me. You can also try these steps to fix this problem:

    1. Open your php.ini file. From above information, It seems your path to the php.ini file will look like this: C:\Documents and Settings\secretary\My Documents\Downloads\xampp\php\php.ini
    2. Replace "display_errors = On" with "display_errors = Off" (without quotes)
    3. Replace "display_startup_errors = On" with "display_startup_errors = Off" (without quotes)
    4. Save this file.
    5. Restart Apache and MySql services from Xampp Control Panel.

    These errors will no more be displayed. Please let me know this trick worked for you or not.

  3. Subash Manickam
    Member
    Posted 1 year ago #

    @mseriesco - yes its working fine.

  4. alberrrrt
    Member
    Posted 1 year ago #

    @mseriesco, Hello. Thanks a lot, but I want to know about a nature of this error. So, any ideas? Why get_the_ID() doesn't work? :)

  5. mseriesco
    Member
    Posted 1 year ago #

    @alberrrt: Sorry, but I don't know the programing of this theme.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.