WordPress.org

Ready to get started?Download WordPress

Forums

ABSPATH problem (4 posts)

  1. Ronaldo_SL
    Member
    Posted 4 years ago #

    This WordPress site I'm working on works fine, but there's one image uploading tool in the dashboard that the previous person taking care of it created/installed that I get this error message where it's interface should be. This happened when we moved the site. I don't know anything about the image uploading thing but I assume the error message is generic will speak for itself:

    Warning: require_once(./wp-settings.php) [function.require-once]: failed to open stream: No such file or directory in /home1/worldcl7/public_html/blog/wp-config.php on line 80

    Fatal error: require_once() [function.require]: Failed opening required './wp-settings.php' (include_path='.:/usr/lib64/php') in /home1/worldcl7/public_html/blog/wp-config.php on line 80

    Line 80 being the "require_once(ABSPATH . 'wp-settings.php');" line. The other lines pertaining to ABSPATH might be relevant so:

    /** Absolute path to the WordPress directory. */
    if ( !defined('ABSPATH') )
    define('ABSPATH', dirname('__FILE__') . '/');

    /** Sets up WordPress vars and included files. */
    require_once(ABSPATH . 'wp-settings.php');

    Any idea what the issue is? There's really nothing wrong with any other part of the site, only this one thing seems to take issue with ABSPATH.

  2. Samuel B
    moderator
    Posted 4 years ago #

    error says this file is missing
    /wp-settings.php

  3. Ronaldo_SL
    Member
    Posted 4 years ago #

    It's there though, where it should be. Is it looking in the wrong place perhaps?

  4. Jeremy Clark
    Moderator
    Posted 4 years ago #

    It might be there but have the wrong permissions.
    http://codex.wordpress.org/Changing_File_Permissions

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.