WordPress.org

Ready to get started?Download WordPress

Forums

Absolutely stumped at why my child theme does not behave like its parent (5 posts)

  1. Nos402
    Member
    Posted 1 year ago #

    I am using a child theme of "Mystique" that I have made a few customizations on. If you go this page you will notice that the full entry is not displaying. It cuts off right at the comments. If you click the comments tab, then it will cut off the top half of the page. With the default Mystique theme, it displays the full page. Now here's where I'm baffled.

    At one point in testing, I deleted EVERYTHING from my child theme folder except a style.css sheet which had the required header but no other additional CSS rules, just the line importing the original Mystique CSS. Even then, my theme cuts off the page. Then I deleted that line as well leaving ONLY the header in the child theme style.css. Sit still looked the same and cut off the page. The only way this page (and other long entries) display correctly is if I activate the original Mystique theme. Shouldn't my empty child theme have been exactly the same as the original parent?

    I even created a brand new child theme and it cuts off the page as well.

    Most importantly how can I fix this display issue? I even compared the view source code from both versions (parent themed and child themed) and found no differences.

  2. Nos402
    Member
    Posted 1 year ago #

    I've narrowed it down to the "primary-content" div. For some reason it's a different height in the child theme than the parent theme even though all styling is identical.

  3. Nos402
    Member
    Posted 1 year ago #

    Further narrowed it to JQuery. If I turn that off in the Mysticque settings, my page works but I lose some functionality, of course.

  4. Nos402
    Member
    Posted 1 year ago #

    Solved! Kind of...
    The difference between the parent and child were that the parent had the first 6 check boxes under "Mystique Settings>Advanced" all checked. Specifically the "optimize website for faster loading" is the culprit. Not sure why I had that unchecked in my child theme.

  5. leejosepho
    Member
    Posted 1 year ago #

    I have done things like that.

    Glad you git it straight.

Topic Closed

This topic has been closed to new replies.

About this Topic