WordPress.org

Ready to get started?Download WordPress

Forums

Absolute privacy: You do not have sufficient permissions to access this page. (15 posts)

  1. beniEllis
    Member
    Posted 3 years ago #

    Upgraded Absolute Privacy and am receiving error: "You do not have sufficient permissions to access this page" when I click on the link in the email notification the plug-in sends me.

    This is the link throwing the error:
    /wp-admin/options-general.php?page=absolute-privacy/absolute_privacy.php&mode=moderate&id=19

    Help?

  2. esmi
    Forum Moderator
    Posted 3 years ago #

    Deactivate the Absolute Privacy plugin.

  3. beniEllis
    Member
    Posted 3 years ago #

    But I am using it to privatize my blog... My blog is accessible and functioning, but I cannot access the users panel via the email link.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    Try another privacy plugin. Obviously, the current version of Absolute Privacy is either broken or is conflicting with another plugin or your theme.

  5. johnkolbert
    Member
    Posted 3 years ago #

    Are you using v2.0.5? The link causing that error is a url from v 1.3.

    v2.0.5 should have the link formatted: get_bloginfo( 'url' ) . '/wp-admin/users.php?page=functions.php&u_id=' . $user_id,

  6. beniEllis
    Member
    Posted 3 years ago #

    Yes, I am.

  7. johnkolbert
    Member
    Posted 3 years ago #

    Was the message that sent that link sent before or after you upgraded? Can you access the Absolute Privacy settings page? Is yes, what is the setting for the message sent to the admin saying there is a pending approval?

  8. beniEllis
    Member
    Posted 3 years ago #

    The email message was received a day ago. I clicked the link in the email today and received the error message. I updated the plug-in (today) and tried the link from the email again. Same error message.

    I can access the admin page of the blog just fine. Everything else seems to work, but the email doesn't capture the ip address of the person registering, so I follow the email link back to the request on the blog to get the ip address.

    I am and have been using the default message settings.

  9. johnkolbert
    Member
    Posted 3 years ago #

    Any messages sent before you updated will have the incorrect link in them. The plugin was updated quite drastically for v2.0, so the URL of the moderation page changed (thus the error your getting). The new URL is http://www.yoursite.com/wp-admin/users.php?page=functions.php&u_id=xx

    Where xx is the user ID of the person you are moderating, which is 19 based on the link you posted in the first post. You can, alternatively, click on the 'Moderate' link under 'Users' (in the side panel of links in the admin area) for a list of all users awaiting moderation.

    Hope that helps.

  10. beniEllis
    Member
    Posted 3 years ago #

    No problem.

    Any chance that in the future you might include the ip address of the person registering in the email?

  11. johnkolbert
    Member
    Posted 3 years ago #

    Yes, it makes sense to include the IP address. I'll add it on my todo list. Thanks for the input.

  12. chicagofabulous@gmail.com
    Member
    Posted 3 years ago #

    I had the same problem once I deleted the ping.fm plugin I was using, everything went back to normal:)

  13. DMaxPWR
    Member
    Posted 3 years ago #

    Hello, I don't want to post another thread about a similar topic. I get this same "You do not have sufficient permissions to access this page" message when I click on the "absolute privacy" tab in my admin.

  14. johnkolbert
    Member
    Posted 3 years ago #

    Can you post the URL of the options page (you can remove your domain name for privacy)? A previous user was getting this message because he renamed the plugin folder with something that contained a 'space' in it. Did you do something similiar?

  15. DMaxPWR
    Member
    Posted 3 years ago #

    Not sure if this is the right url you ask for:
    wp-admin/options-general.php?page=absolute-privacyv2.0.5/functions.php

    No I haven't changed anything with the folder :d

    Thanks for the help!

Topic Closed

This topic has been closed to new replies.

About this Topic