WordPress.org

Ready to get started?Download WordPress

Forums

Absolute Privacy - Cannot approve users (8 posts)

  1. Dave MacNeil
    Member
    Posted 3 years ago #

    This plugin has worked for me without any issues whatsoever for over a year...until I upgraded this morning to WP301. Now, I approve a new user and they just perpetually remain in the queue, never able to log in even though they have recieved the approval email. AP says they have been approved, but the login fails and when I go back to check after the login failure, they are back in the moderation queue, unable to login. This is perpetual.

  2. Dave MacNeil
    Member
    Posted 3 years ago #

    Of course, the workaround would be to deactivate it for the time it takes for an administrator to create the new user, then reactivate it once that is done.

  3. johnkolbert
    Member
    Posted 3 years ago #

    A new version of Absolute Privacy is coming out shortly that is compatibile upto WP 3.1-alpha

  4. johnkolbert
    Member
    Posted 3 years ago #

    v2.0 of absolute privacy was just released. I'd be interested in seeing if your experience changes.

  5. AC
    Member
    Posted 3 years ago #

    Hi! I'm having the same issue with the user approval loop as described above and I just emailed you (John) directly regarding this. As stated, I approve the user, it says a notification will be sent, it does in fact get sent, but then the same user shows up in the moderate users list and is still showing as unapproved. The user never really gets approved and cannot log in, even though they receive a notice that they have been approved.

    Thanks!
    -Angela

  6. johnkolbert
    Member
    Posted 3 years ago #

    I've gotten a few more reports of this. I haven't been able to replicate it, but I'm going to spend some time over the weekend doing so. Keep your eye on this post for more info. Thanks!

  7. johnkolbert
    Member
    Posted 3 years ago #

    Ok, those having this problem right now should upgrade to v2.0.4 which I just released. Then go to Settings->General and make sure "Unapproved" is NOT set to your default role. Make it subscriber (or whatever fits your site).

  8. AC
    Member
    Posted 3 years ago #

    Hi John!
    I finally found some time to upgrade and follow the action you listed above. Just wanted you to know everything is working great now. Thank you for an awesome plugin! :)

    -Angela

Topic Closed

This topic has been closed to new replies.

About this Topic