WordPress.org

Ready to get started?Download WordPress

Forums

able to login back-end, but BLANK at front end url (23 posts)

  1. malibu06
    Member
    Posted 4 years ago #

    I just transferred a blog to a new URL. basically replacing old HTML site with WP site.

    - FTP'd content and files
    - imported mySQL db uploaded properly...
    - i login to /wp-admin.php and everything is there, pages, media files, posts, etc.
    wp-config.php seems to be correct...
    however, nothing loads at main URL http://www.artcretedesigns.com/
    (if inappropriate to post up URL - admins, please let me know)

    does anyone have any ideas of what I might be missing?

    thanks!
    Matt

  2. malibu06
    Member
    Posted 4 years ago #

    just a clarification:

    I have deleted index.html so there is only

    index.php

    also tried adding .htaccess as below, but nothing...

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
  3. malibu06
    Member
    Posted 4 years ago #

    looking at the source code for the main url it shows

    <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
    <HTML><HEAD>
    <META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>
    <BODY></BODY></HTML>

    so, i'm assuming for some reason it is not calling the php files, but everything is there in the backend... really weird...

  4. malibu06
    Member
    Posted 4 years ago #

    I just re-uploaded all WP related files to the new server, changed the wp-config.php file appropriately, but still no luck. Still looking at a blank page...

    anyone???

    thanks!!!

  5. phrz
    Member
    Posted 4 years ago #

    Looks like a PHP syntax error in your theme or your theme's functions.php , or even in one of your plugins. Try using the default theme. If that works. There is an error in one of your theme files. If that didn't work. It could be an error in your plugins. You can check that by de/activating them.

    Good luck!

  6. henkholland
    Member
    Posted 4 years ago #

    Read this one:
    http://wordpress.org/support/topic/341655?replies=14

    Maybe a messed up index.php in the root.

  7. malibu06
    Member
    Posted 4 years ago #

    Hi guys, thanks for the comments.

    Since I'm able to get to backend admin, I tried the following:
    1. changed the theme to default WP theme (kubrick)
    2. deactivated all plugins
    3. republished all posts and pages

    Also, checked wp-config.php to make sure there were no "extra" lines at the end of the file (as I've found that seems to be common error).

    henkholland, i checked my index.php and it looks ok:

    <?php
    /**
     * Front to the WordPress application. This file doesn't do anything, but loads
     * wp-blog-header.php which does and tells WordPress to load the theme.
     *
     * @package WordPress
     */
    
    /**
     * Tells WordPress to load the WordPress theme and output it.
     *
     * @var bool
     */
    define('WP_USE_THEMES', true);
    
    /** Loads the WordPress Environment and Template */
    require('./wp-blog-header.php');
    ?>
  8. malibu06
    Member
    Posted 4 years ago #

    another thought... not sure if this could be an issue...

    when I prepped the mySQL DB for upload to the new server, I changed all references from the old URL to http://WWW.artcretedesigns.com instead of just http://artcretedesigns.com

    i also have the URL in the settings panel pointing to http://www.artecrete.com

    I think that should be OK as I've done it before...

  9. malibu06
    Member
    Posted 4 years ago #

    one more thought...

    the site was designed in WP 2.8.5

    the new server has 2.5.6

    thanks!

  10. henkholland
    Member
    Posted 4 years ago #

    And that index.php is in the root, right, next to wp-contig.php etc?

  11. malibu06
    Member
    Posted 4 years ago #

    yes,
    the root has the three folders
    wp-admin
    wp-content
    wp-includes

    and then the files
    index.php
    wp-config.php
    etc. etc...

  12. imack03
    Member
    Posted 4 years ago #

    My server support sent this information:

    I do note that the cgi_error_log [which can be found in the 'stats' folder of your account] has a lot of errors at the end:

    PHP Fatal error: Call to undefined function is_admin() in /hermes/web03/b512/moo.imack03/day/wp-includes/vars.php on line 16

    I have heard of other customers having an issue with WP 2.9, and the error message does support there being a problem of some sort with the code. Reverting back to the previous version would seem the best bet at this point.

  13. malibu06
    Member
    Posted 4 years ago #

    you can see my cgi error log? wow! I'm not sure if that is good or bad?

    I'm not on 2.9 now... just developed the site in 2.8.5, but installed 2.8.6 on the new server that I transferred everything to... I'll check into how to revert back to 2.8.5 on the new server.

    Is there anything else that I can do to fix the PHP Fatal error in vars.php?

  14. henkholland
    Member
    Posted 4 years ago #

    Imack is referring to his own problem!! It says Imack in this line: hermes/web03/b512/moo.imack03/day/wp-includes/vars.php

    There's nothing really between 2.8.5 and 2.8.6 so I would not bother.

    Two questions left for me:
    1. Since you have sql/server access, are there any error logs there?
    2. This would not be a host that does not like stuf in the root (or is the "root"stil within "http" or "public_html" or something like that?

    Note: I saw that you did put the html site back on. No problem: url + index.php still goes to your problem.

  15. henkholland
    Member
    Posted 4 years ago #

  16. malibu06
    Member
    Posted 4 years ago #

    hi henk,

    1. no error logs that I can see
    2. on the FTP structure, there is actually nothing in the root folder except a folder "artcretedesigns" that everything is in... cgi-bin, index.html etc...

    I wonder if I need to rewrite the htaccess to

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /artcretedesigns/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /artcretedesigns/index.php [L]
    </IfModule>
    
    # END WordPress

    I just tried that, and nothing... so maybe something similar??

  17. malibu06
    Member
    Posted 4 years ago #

    another thought... i don't think this would work... but...

    On the general settings page, should I change the URL and blog address to
    http://artcretedesigns.com

    instead of the http://www.artcretedesigns.com ?

    I was going to try, but then I'm afraid I may not be able to get into the back-end if something goes wrong...

  18. henkholland
    Member
    Posted 4 years ago #

    ....nothing in the root folder except a folder "artcretedesigns" that everything is in... cgi-bin, index.html etc...

    Rename that index.html to indexold.html (where does it come from and what did it do?)

  19. malibu06
    Member
    Posted 4 years ago #

    Hi Henk,
    Yeah, I've tried renaming the original index.html and deleting it a few times, but no luck. It is from the old HMTL site.

  20. henkholland
    Member
    Posted 4 years ago #

    Hi Malibu,

    How about emailing me an ftp login; i feel like blindfolded here and it takes too long now. Set up a new ftp user and test it and email me at hvanderspekathotmail.com

  21. Michael Bishop

    Posted 4 years ago #

    Have you tried turning debugging on? Simply add define('WP_DEBUG', true); to your wp-config file, this might shed some light. I'd warn against sharing FTP access, despite seemingly good intentions.

  22. malibu06
    Member
    Posted 4 years ago #

    Hi guys,
    Thanks for all the help! One of my buddies fixed the issue. I need to detail what he found and post it up.

  23. dangrahn
    Member
    Posted 4 years ago #

    Having the same issue.

    malibu06, could you share the fix?

Topic Closed

This topic has been closed to new replies.

About this Topic