WordPress.org

Ready to get started?Download WordPress

Forums

Advanced Access Manager
AAM blocks post-listing on the front-end (7 posts)

  1. schwarzgrau
    Member
    Posted 1 year ago #

    I use posts-2-posts for connections between posts. Then I list them on the front-page.
    If im logged-in I can see all posts, but If I log-out I can only see some of them, altough they are all public and published.
    If I deactivate AAM I can see all connections, even if I'm logged-out.
    But I can't find settings for not registered users.

    http://wordpress.org/extend/plugins/advanced-access-manager/

  2. WP AAM
    Member
    Plugin Author

    Posted 1 year ago #

    Hi schwarzgrau,
    Please check this tutorial: http://whimba.org/forum/viewtopic.php?f=6&t=8

    Regards,
    Vasyl

  3. schwarzgrau
    Member
    Posted 1 year ago #

    Wow, I never got such a fast reply here on the forum. Thank you Vasyl.
    For me only this url works, but I guess it's the right tutorial.

    Even if I set the Capabilities of _Visitor to Admin, I can only see some posts.

  4. WP AAM
    Member
    Plugin Author

    Posted 1 year ago #

    Weeeell.
    First of all capabilities has nothing to do with visitor. That is why any changes to capabilities have no effect. What I'm suggesting is to select Current Role _Visitor and click restore default button (arrow next to save button).
    Try this and let me know the result

    Regards,
    Vasyl

  5. schwarzgrau
    Member
    Posted 1 year ago #

    Good to know.

    Unfortunately nothing changed, after restoring the default-settings for visitors.
    I dumped the posts which gets displayed, with the ones which doesn't get displayed and can't find the difference.
    But if I dump a post logged-in and logged-out there is a difference:
    In some posts the meta-key 'connected', which is created by posts2posts to store the connected posts, is empty.
    Unfortunately I can't find a pattern in it.

  6. schwarzgrau
    Member
    Posted 1 year ago #

    I tried to create a connection with AAM activated and another one with AAM deactivated, but both connections are invisible if I activate AAM.
    It seems like there is some general incompatibility between Advanced Access Manager and Posts2Posts. Unfortunately there is no alternative to Posts2Posts.

  7. schwarzgrau
    Member
    Posted 1 year ago #

    Finally I found the problem:
    AAM seems to block connections from Posts2Posts if you use meta_keys to order them. I still don't know why, but maybe useful for everyone, who struggles with the same problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic