WordPress.org

Ready to get started?Download WordPress

Forums

AAAAHH what did I do in my options? (4 posts)

  1. psharbaugh
    Member
    Posted 6 years ago #

    I just set up a new blog and everything was going great. I'd successfully installed two popular plugins and was configuring the blog's basic options ... and somehow made a minor change so that now my main blog URL and /installs URL give me only Index pages. Worse, it won't allow me to login and make administrative changes. I'm completely locked out. I can't imagine what I did to cause this, but here's what I was doing right before it happened:

    On the options page (I think) there's was an option to change the main blog URL and the "installs" URL. Naturally, I want people to type in my blog name and get the blog itself instead of an index page, as I was getting. So I changed the main blog address in the options window from http://www.manandultraman.com/installs to just http://www.manandultraman.com/ and then I hit "Update Options."

    Now I'm locked out of my own blog (oh the ignominy). I can pull up nothing but two index pages, and I'm clueless and optionless. Help!

  2. MichaelH
    Member
    Posted 6 years ago #

    To get back to where you were, use this tutorial: http://www.tamba2.org.uk/wordpress/site-url/

    Now to set it so visitors see your WordPress at http://www.manandultraman.com

    1. In Administration > Options > General, change your Blog address (URL) to http://www.manandultraman.com. Please note your WordPress address (URL) should be http://www.manandultraman.com/installs (no trailing /).
    2. Create an index.php in web-root folder (same folder that holds wordpress):

    <?php
    /* Short and sweet */
    define('WP_USE_THEMES', true);
    require('./installs/wp-blog-header.php');
    ?>

    3. Update your permalinks.

    Even though the actual WordPress files reside in a sub-directory, with index.php file in your webroot, and the with Options->General admin page Blog address (URL) is changed so that WordPress acts as your main page. This particular setup is described at: http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory

  3. psharbaugh
    Member
    Posted 6 years ago #

    Holy smokes .... thanks for the advice but I don't even know what phpMyAdmin is, much less how to install, configure, and use it per the install instructions. I'm not a coder of any kind. I downloaded it, but I might as well have a brain surgery patient on a table in front of me and be told, "First, go ahead and fix the brain."

    Is there any other way of fixing this problem without using phpMyAdmin?

  4. MichaelH
    Member
    Posted 6 years ago #

    Most hosts offer access to phpMyAdmin and I believe Dreamhost does also.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.