WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Aaaaaargh...Disaster !! Blog post isn't displaying fully on site. (9 posts)

  1. swearbox
    Member
    Posted 1 year ago #

    I'm about to lose the plot here. First some background. I've recently deployed a site which so far has no pages except the homepage on which I have written one post that has so far attracted one comment to which I have replied.

    I submitted my sitemap xml pages (as generated by Yoast's SEO plugin) to Google but something wasn't right. I had expected my updated page to be indexed more quickly that it was. Google Webmaster Tools told me that the sitemap xml pages contained errors (being in HTML format not supported blah blah). Googling around I found this problem wasn't uncommon so I elected to switch off the xml sitemap functionality in Yoast's plugin and install Google XML Sitemaps plugin to handle this functionality. I resubmitted the new sitemap info to GWT and two days later I see it is already showing as 'indexed'.

    The issue I have now is that when I go to my site http://www.thefibromyalgiadiet.com it shows the page as normal, ie just the one post and a snippet of the content, and the sidebar looks OK but when I hit any of the links Read More, Comments, Read Full Article, basically anything that links to the full post the site page simply refreshes. I really can't think of anything that I've done to cause this. I'd be mighty grateful if anyone can show me what's gone wrong. Thx in advance.

  2. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    Are you using a static front page?

  3. swearbox
    Member
    Posted 1 year ago #

    To be honest I can't find a setting within the Admin panel that tells me this...I looked in Settings/Reading but nothing shows up there. My Pages/All Pages says 0 pages found...beyond that I don't know where else to look.

  4. wp_sam
    Member
    Posted 1 year ago #

    Do this:

    set your site permalink to default and check if the problem is still there it may be issue with .htaccess file.

    check this link for more details http://codex.wordpress.org/Using_Permalinks

  5. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    If it's not in your Settings/Reading section, is there anything in Appearance > Themes and then in the 'customise' section on the current activated theme?

  6. swearbox
    Member
    Posted 1 year ago #

    Went to Customize section for installed theme..it says front page displays Latest Posts.

  7. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    Can you try wp_sam's suggestion? It got caught up in the spam filter and was hidden.

  8. swearbox
    Member
    Posted 1 year ago #

    Panic over...I fixed it. in the Yoast SEO configuration for the post I had a 301 redirect in one of the fields that pointed to the URL of the site...so I guess that every time you click on any element within the post it redirects to the front page...which only shows the snippet...jeez, there's so much to learn. Thanks for taking the time Andrew, really appreciate the work you guys do, always prompt :-)

  9. Andrew Nevins
    Barrel Rider, Spam Zapper & Volunteer Moderator
    Posted 1 year ago #

    And Thank you for contributing to the WordPress community :)

Topic Closed

This topic has been closed to new replies.

About this Topic