WordPress.org

Ready to get started?Download WordPress

Forums

Achievements for WordPress
[resolved] A new user activates... achievement (17 posts)

  1. DCrash
    Member
    Posted 1 year ago #

    Hi Paul, ditto on great plugin and everything.
    I'm having problems getting a new user activation achievement to trigger. Other achievements are working.

    I'm using a clean wp 3.5.1 install, 2012 theme, with all plugins deactivated except bp 1.7.1 and achievements 3.3

    I created a event achievement with
    A new user activates their account on your website.
    selected from the buddypress group.

    thanks

    http://wordpress.org/extend/plugins/achievements/

  2. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 1 year ago #

    Hi. To check I've understood:

    The user recieves the activation email from BuddyPress, they click the link, BuddyPress confirms the account is activated, and then the user logs in, and is NOT "award" the achievement?

  3. DCrash
    Member
    Posted 1 year ago #

    Hi Paul,
    Yes correct, after they register/activate then login, they are not awarded the achievement.

  4. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 1 year ago #

    :(

    Looks like it could be a bug. Will investigate for next release.

  5. pmcvicker
    Member
    Posted 1 year ago #

    I can confirm the same. Badge awarded on activation for the first time I tested it, and then not at all for any users after that.

  6. Marshall
    Member
    Posted 1 year ago #

    Same here. I saw the badge awarded when i first tested it on a couple of users but now is not working. I thought there was a conflict with another plugin but since other people has the same problem it's probably a bug...?

    Amazing plugin by the way. Great job Paul!

  7. mfletch512
    Member
    Posted 1 year ago #

    I am having the same problem, any idea when this will be resolved? Loving the plugin so far. thanks

  8. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 1 year ago #

    Maybe in the next release. Which I don't know when it will be yet.

  9. mfletch512
    Member
    Posted 1 year ago #

    alright, cool. thanks

  10. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 1 year ago #

    After spending some hours looking at this, it is a fundamental bug and I'm not sure how it *ever* worked. I am probably going to remove this action from Achievements 3.4 as it's due to some funkiness in BuddyPress.

  11. xValkyrie
    Member
    Posted 1 year ago #

    Remove the "A new user activates their account on your website." under buddypress? Oh man that's going to really stink for some of us who have user points displayed. Since they start out with blank points instead of 0 or 1 it just shows up empty when a new user joins unless you use this achievement. Plus everyone loves seeing that first achievement right away. I get a lot of compliments from new users because of it.

    Please consider fixing it if possible, or at least giving a default 0 or 1 point so it won't display blank. I know that we could probably use invite anyone, but really I just don't need it and I hate to add a plugin just to support another.

    Btw, I love this plugin so much, excellent work sir.

  12. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 1 year ago #

    I can't figure out how it ever worked, even less why it broke all of a sudden. I tested Achievements against BuddyPress 1.7 (which was the earliest version that Achievement 3.x supported), and still doesn't work.

  13. xValkyrie
    Member
    Posted 1 year ago #

    Darn. That's an odd one, oh well then. I suppose we would still be able to use invite anyone for this purpose then? If it was possible to set some sort of default value to all new subscribers at least, like 0 or 1, it could help those displaying points. You run into some odd situations with blank points. Just a thought.

  14. bymiki
    Member
    Posted 8 months ago #

    Hello, This is already solved? I set both events "Create new account" and "Activate Account" and I can not get it to work.
    I am using Achievements 3.5.1, WP 8.0 and BP 1.9

    Thanks

  15. Paul Gibbs
    BuddyPress Lead Developer
    Plugin Author

    Posted 8 months ago #

    Hi bymki -- I mark the support topics here as resolved when I've left a response.

    There is still at least one bug around detecting account activation and BuddyPress, it's best to keep an eye on https://github.com/paulgibbs/achievements/issues/102

    It's not been fixed yet. I haven't looked at it in a few months, I think I might end up adjusting BuddyPress to work better.

  16. bymiki
    Member
    Posted 8 months ago #

    Ok, thanks Paul

  17. Unit9
    Member
    Posted 6 months ago #

    Hi Paul,

    I hope you're well! :D

    I just wanted to register my interest in a fix for this as well.

    I've got a couple of achievements in place for this, like 'Founding Member' but obviously right now no one can unlock them while this feature isn't working.

    Would love to see this working again! :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.