WordPress.org

Ready to get started?Download WordPress

Forums

WP SlimStat
[resolved] a misconfigured setting and/or server environment is preventing WP SlimStat from (24 posts)

  1. hauseda
    Member
    Posted 1 year ago #

    Just upgraded to Slimstat v 2.8.6 and am receiving the "a misconfigured setting and/or server environment is preventing WP SlimStat from properly tracking your visitors." I double checked the file "wp-slimstat-js.php" and it is in fact located in the directory "/wp-content/plugins/wp-slimstat/" and appears OK. Any thoughts as to resolution? Thanks, Dave

    http://wordpress.org/extend/plugins/wp-slimstat/

  2. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Have you tried to access it directly with your browser? Do you get any server errors?

    Camu

  3. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Is this your site?

    http://dragonleather.net/what-i-do/

    It looks like the javascript is not being added to the page. I bet it's related to the caching plugin you're using on your site. WP SlimStat is officially incompatible with W3 Total Cache & co, sorry. You're also using a source compressor, which might be the cause. Also, you have an error on this javascript file

    http://dragonleather.net/wp-content/w3tc/min/64d6531e.2ba68e.js

    which could be affecting the tracking functionality as well.

    Take care,
    Camu

  4. hauseda
    Member
    Posted 1 year ago #

    Yes Ive tried a direct access and yes that's my page, accessed directly and it went to my custom 404 page. Thanks on the rest. Was all working fine until the upgrade to 2.8.6. I'll check to other stuff out.

  5. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Thank you.

    Unfortunately it wasn't "working fine", the misconfiguration was just not being detected and pointed out ;)

    Let me know how it goes... that error 404 doesn't seem right!

    Camu

  6. alexdex
    Member
    Posted 1 year ago #

    Hi, after the update i have the same problem.
    If i access directly to the php file i have a 500 error server, so i check the file from ftp and the new plugin change the permission from 755 to 644, i repair the permission and now the php page wp-slimstat-js.php write: Invalid data format

    But i have always the error:
    WARNING: a misconfigured setting and/or server environment is preventing WP SlimStat from properly tracking your visitors. Please check the FAQs for more information.

    Please help me

  7. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Invalid data format is the expected error message, so now you should be okay. The warning message in your admin will go away as soon as a human visitor will access your site and the script will complete its execution without any errors.

    Let us know if it worked!

    Camu

    Ps a vote for my plugin would be a nice way to say thank you!

  8. d5f7p9
    Member
    Posted 1 year ago #

    Our website uses Slimstat ver 2.8.5 and W3 Total Cache and they seem to work OK together. Further back in this thread, in response to someone having problems with ver 2.8.6 you state that "WP SlimStat is officially incompatible with W3 Total Cache". Does that mean that I shouldn't upgrade to to version 2.8.6?

  9. camu
    Member
    Plugin Author

    Posted 1 year ago #

    Hi there,

    no, it means that OFFICIALLY my plugin has never been compatible with W3 Total Cache. If it works for you, then you can upgrade without any problems.

  10. nsachc
    Member
    Posted 1 year ago #

    Hi, I like the plugin, and it was working fine until the upgrade. I've read everything I can on this issue but you simply say fix. You don't say HOW.

    I changed permissions to 775 on everything in the Slimstat folder and still I get the misconfigured setting error.

    How do I fix so Slimstat works?

    Thank you.

  11. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I can't say HOW simply because there are so many things that could cause this problem, usually based on each provider's server configuration ;)

    Have you tried to access that file directly? What message do you get?

    Thanks for your patience
    Camu

  12. nsachc
    Member
    Posted 1 year ago #

    Appreciate the response.

    No error message. Just page not found.

    Within WordPress it still says WARNING: a misconfigured setting and/or server environment is preventing WP SlimStat from properly tracking your visitors. Please check the FAQs for more information. But it worked until recent upgrade.

  13. camu
    Member
    Plugin Author

    Posted 1 year ago #

    So in your opinion "Page not found" is NOT an error message? :) Did you read the FAQs?

    The error message you should be getting is *Invalid data format*, which is the expected behavior.

    Please come back when you get that message.

    Thank you.
    Camu

  14. Ian
    Member
    Posted 1 year ago #

    Hi there.

    I'm getting parsing "Error parsing wp-config" message when viewing it in the browser?

    http://www.example.com/sub-folder/wp-content/plugins/wp-slimstat/wp-slimstat-js.php

    What does that mean and how can I fix it?

  15. camu
    Member
    Plugin Author

    Posted 1 year ago #

    It means that you moved your wp-config somewhere else. The next version will have a smarter approach, but for now you need to edit the second line of wp-SlimStat-js.php

    Let me know if that helps

    Camu

  16. nsachc
    Member
    Posted 1 year ago #

    Camu, I don't know what to do to get that error.

    I have read the other threads and made sure my permissions on all files in the slimstat folder are 775.

    What else do I need to do please?

  17. nsachc
    Member
    Posted 1 year ago #

    Camu, I don't know what to do to get that error.

    I have read the other threads and made sure my permissions on all files in the slimstat folder are 775.

    What else do I need to do please?

  18. camu
    Member
    Plugin Author

    Posted 1 year ago #

    @nsachc, access /wp-content/plugins/wp-slimstat/wp-slimsta-js.php directly on your website and see what happens.

  19. nsachc
    Member
    Posted 1 year ago #

    I have. Per my message above, it gives me a page not found error.

  20. Ian
    Member
    Posted 1 year ago #

    Hi @Camu, thanks for your reply.

    But as soon as I tried to change the location for this:
    $wp_root_folder = '../../..';

    For example to:
    $wp_root_folder = '../../../..';
    $wp_root_folder = '../..';

    I get:
    Error: wp-config not found

    The file is in the correct location:
    http://www.example.com/wordpress-installed-here/wp-config.php

  21. camu
    Member
    Plugin Author

    Posted 1 year ago #

    I see, then it means one of the following values is not initialized in your wp-config:

    'DB_NAME'
    'DB_USER'
    'DB_PASSWORD'
    'DB_HOST'
    '$table_prefix'

    which is weird... unless there's something I'm missing :)

  22. camu
    Member
    Plugin Author

    Posted 1 year ago #

    @nsachc, would you please start a new thread? This is getting confusing. If the file is not found, then it means that it's not where it should be.

    Page not found... IS AN ERROR MESSAGE ;)

  23. Ian
    Member
    Posted 1 year ago #

    Hi again,
    I checked wp-config.php and it has all those values entered.

    But this one is blank in the quotes, like this:
    $table_prefix = '';

    The plugin seems to be recording the stats fine however, so if it is, then will leave it for now. Cheers :)

  24. camu
    Member
    Plugin Author

    Posted 1 year ago #

    No, wp SlimStat is not working properly, but if you want to leave like that... You're the master :)

    Ps a vote for my plugin would be a nice way to say thank you

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.