WordPress.org

Ready to get started?Download WordPress

Forums

NinjaFirewall (WP edition)
[resolved] A conflict with the caching plugin (7 posts)

  1. Sloba
    Member
    Posted 6 months ago #

    Hi,

    I've installed the Ninja Firewall recently and it seems it has a conflict with the Quick Cache plugin.

    The problem appears only on mobile device.
    When the Ninja Firewall is active Quick Cache doesn't show its notes when the page source is seen over the mobile device.
    It seems that pages are cached (even on mobile), it's just that notes are missing.

    On the desktop everything is working fine.

    http://wordpress.org/plugins/ninjafirewall/

  2. nintechnet
    Member
    Plugin Author

    Posted 6 months ago #

    Hi,

    What do you call 'notes' ?
    Is it the comment line appended to the HTML code and only visible when viewing the page source, like this one:

    <!-- This Quick Cache file will auto-expire (and be rebuilt) on: .... (based on your configured expiration time -->

  3. Sloba
    Member
    Posted 6 months ago #

    yes, the comment line added by Quick Cache is missing. If I deactivate Ninja Firewall it will appear.

    This way I'm not sure are pages cached on mobile devices.

  4. nintechnet
    Member
    Plugin Author

    Posted 6 months ago #

    I cannot reproduce that error. I tested on 2 different phones with 6 browsers and it worked, with or without NinjaFirewall:

    WordPress: 3.8
    NinjaFirewall: 1.1.5
    Quick Cache: 131206

    1) iPhone 5s, iOS 7.04:
    -Dolphin Browser 7.5.1
    -Safari (stock browser)
    -Opera Mini 7.0.5.45339

    2) Samsung Galaxy S3, Android 4.1.2:
    -Android stock browser
    -Dolphin Mini 2.3
    -Opera Mini 7.5.3

    Which browser and phone are you using ?

  5. Sloba
    Member
    Posted 6 months ago #

    I'm using Android. I think there's no logic that it's related to the user agent. Immediately after I disable the Ninja Firewall the comment line will appear.

    I've tried seeing it through the http://www.ready.mobi/ and the same thing happens:
    - with the Ninja Firewall enabled: there's no Quick Cache comment line
    - with the Ninja Firewall disabled: there's a Quick Cache comment line

    Also I tried disabling some options from the Firewall but it didn't help. Only when the Firewall is disabled the Quick Cache line will come back.

    I think I didn't say it's the Multisite installation. Actually I have 2 Multisite installations as a test environments and the same issue appears on both instances.

    I didn't activate Ninja Firewall on regular WordPress yet (without Multisite), so I cannot say about that.
    Have you tested this in Multisite environment?

  6. nintechnet
    Member
    Plugin Author

    Posted 6 months ago #

    I didn't test with a Multisite installation. I will try to do that later this week.
    You can try to enable WordPress debugging mode, it may help to see error (if any), by adding this to your wp-config.php file:

    define('WP_DEBUG', true);
  7. nintechnet
    Member
    Plugin Author

    Posted 6 months ago #

    That plugin has a syntax error, in advanced-cache.tpl.php line 110.
    The regex has an unmatched closing parenthesis:

    if(is_multisite() && preg_match('/\/files[\/?$])/', $_SERVER['REQUEST_URI'])) return;

    Since that line affects multisite only , you may try to remove the unmatched ')' from the regex and check again if that works.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.