WordPress.org

Ready to get started?Download WordPress

Forums

DB Toolkit
{{_ViewLink}} not working when Enable custom template checked (2 posts)

  1. Shanhua
    Member
    Posted 1 year ago #

    Dear Desertsnowman,

    Are you available to do troubleshooting for hire? If so, would you please let me know your rates? I would gladly pay for your assistance.

    Here is my problem:

    I've got DB Toolkit working for an employee database. Names are linked in a list of employees, and clicking on the link takes you to that employee's individual page.

    So far, so good.

    But, when I try to customize the list template (by checking the Enable box: Set this interface to use custom list templates) and enter the following code in the row content box, save, and then bring up the list page, I get a 404 error when I click on an employee's name in the list.

    When I uncheck the Enable box, the links work again -- but then the page looks terrible?!

    This is the template code I am using:

    <div style="float:left;">
    <a href="{{_ViewLink}}">{{first_name}} {{last_name}}</a>, {{position}} ({{location}})
    </div><div style="clear:left;"></div>

    The list page is at:

    http://avrdc.org/?page_id=4408

    It seems a small problem, but I am at a loss as to how to fix it.

    DBToolkit is a very handy plugin. Thanks for sharing it. Hope to hear from you soon.

    http://wordpress.org/extend/plugins/db-toolkit/

  2. delcohistory
    Member
    Posted 12 months ago #

    Hello Shanhua

    I looked at your site, it appears you have not figured this out... I've been having the same issue and found out how to fix it...

    In the App, go to GENERAL SETTINGS

    Scroll down to the 3rd section, LIST SETTINGS

    The 2nd setting, SHOW VIEW (Render the view entry icon) needs to have a checkmark.

    Click APPLY and test.

    This fixed the issue for me.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic