WordPress.org

Ready to get started?Download WordPress

Forums

– inserted in place of two dashes (7 posts)

  1. WilliamM
    Member
    Posted 8 years ago #

    For some reason about 10-20% of had – inserted in the place of two dashes. This makes it so that much of the page doesn´t work properly.

    Here is an example of what I have:

    http://www.silver–bracelets.com/blog/wp-content/themes/copperleafplus1.7/style.css

    When I replace the – with two dashes and save it as html, the page opens correctly.

    What do I need to do?

  2. jdmc
    Member
    Posted 8 years ago #

    WordPress's automatic “text-beautifying? routines are converting your two consecutive hyphens into an en dash. The HTML identifier “–? (or, in hexadecimal, “–?) refers to the en dash in Unicode.

    Instead of typing your pair of hyphens verbatim, try typing the following identifier sequence:

    --

    I expect that this will prevent WordPress from changing them, but I haven’t tested it myself; try it and see if it works.

  3. WilliamM
    Member
    Posted 8 years ago #

    Where do I type the identifier sequence?

  4. jdmc
    Member
    Posted 8 years ago #

    If you’re typing a new post, then wherever you want a pair of hyphens that stays a pair of hyphens, type the sequence I mentioned instead of actually typing two hyphens on your keyboard.

    If you’re editing an existing post to fix it, then wherever there’s an en dash that ought to be a pair of hyphens, simply select the en dash and replace it with the sequence I mentioned.

    The identifier “-? is an “escaped? representation of a hyphen. By disguising each of the two hyphens this way, I’m hoping they’ll slip past the text-beautifying routine without being combined into an en dash.

  5. WilliamM
    Member
    Posted 8 years ago #

    The problem is not with any post but with my blog itself.

    If you go to http://www.silver--bracelets.com/blog/index.php you'll see that the CSS file does not load because of the problem mentioned above.

    If you look at the source code, you will notice that "–" has been inserted in several places.

    Where do I go to have the "–" removed and insert "--"?

  6. WilliamM
    Member
    Posted 8 years ago #

    Can anyone help me resolve this problem?

    What documents do I need to access and what changes need to be made so that my blog will funcion correctly?

  7. Servant
    Member
    Posted 8 years ago #

    For the experts out there that may be able to help, I'll state it another way to perhaps make clearer the problem. His web site's name has two dashes in it, but WP is changing the URL to a single en-dash so that the links are incorrect and it doesn't point correctly to things such as the directory containing his css file. Where does he need to modify his URL by inserting the escaped version (--) of the dashes so all the URLs will be referenced correctly? Is it simply in admin under Options|General or somewhere else?

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic