WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 666 and still uneditable. =( (10 posts)

  1. Keilya
    Member
    Posted 7 years ago #

    Hello

    Recently I changed servers and the move of WordPress was rather smooth.

    WordPress is located in my main directory, ie. exonesis.com.

    However, after I moved, I am unable to edit any file on the server even if I set the file permission to 666.

    I also host my sister's blog in a subdomain and she is able to edit her files via wordpress <i>sometimes</i>. All her files are set at 644.(which was the default, I didn't touch anything. x.x)

    Anybody has any ideas?

  2. yosemite
    Member
    Posted 7 years ago #

    How are you changing permissions (i.e.; are you getting accurate information that the change occured)?

    How were the files 'moved' (uploaded)? Was it with an ftp client? Dreamweaver-ftp? What I'm trying to get at is what user/group was assigned to the files on creation.

  3. Keilya
    Member
    Posted 7 years ago #

    Oh hmm. I changed it via SmartFTP. Just right click on the file and by going to CHMOD. And I simply typed the number 666 there. Then it confirms with me as follows:

    [16:01:24] SITE CHMOD 666 index.php
    [16:01:24] 200 Permissions changed on index.php

    And yep...tt's it. But I still can't edit it. Am I doing something wrong here?

  4. maerk
    Member
    Posted 7 years ago #

    Some servers don't let you write to files unless it's set to 777. This is generally discouraged for security reasons, but you can do it temporarily.

  5. yosemite
    Member
    Posted 7 years ago #

    Does SmartFTP allow you to open/save the file in a local text editor (open/save back to the server)? If so, you may be limited to that unless your host makes changes...

  6. Keilya
    Member
    Posted 7 years ago #

    Hmm..I had a previous server before this and I could edit my files through WP too. And I was using SmartFTP as well.

    If I'm having the problem maerk says, then I guess I have no choice. >.<

    My sister is able to edit her files nicely at 644. Is that a good permission for me to change to?

  7. yosemite
    Member
    Posted 7 years ago #

    644 is a good setting for files (translates to rw-r--r--, everyone can 'read' only the owner can 'write'). If files need to be modified by scripts/PHP then they may need to be 'looser' (664 or lastly 666).

    If you have to use 777 (for scripts) your host is whacked, look for another.

  8. buffmancomic
    Member
    Posted 7 years ago #

    Try uploading one paragraph of your content at a time, then try editing in the other material. There are lists with some host providers of content-blocked material... I had this happen for a humor blog.

  9. Keilya
    Member
    Posted 7 years ago #

    *sigh* I tried 644 too. No do. Sometimes I even get 403 Forbidden Error

    Forbidden
    You don't have permission to access /wp-admin/templates.php on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

    No idea what's wrong. =.= But I guess my host is kinda whacked. I'll just have to do with the Edit on Computer and upload with FTP method. Long and tedious I guess.

    buffmancomic: Thanks but it'll be hell trying to find out which part is causing the error. x.x

    Btw, since we are on this, what's the difference between Execute and Read? I know 'user' refers to me. How about Group? Others refer to the public right?

  10. yosemite
    Member
    Posted 7 years ago #

    More info:
    http://www.dartmouth.edu/~rc/help/faq/permissions.html

    EDIT: Oh, and if you get a 403 error, feel free to ask your host about it. Could be a mod_security issue...

Topic Closed

This topic has been closed to new replies.

About this Topic