WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 60 seconds lo load my blog (11 posts)

  1. luiscarlos98
    Member
    Posted 1 year ago #

    I have a big problem with a bad performance on my blog on WordPress, significantly large web page downloads, using pingdom load time is 60 seconds.

    I have this bad performance not only with the pages that every user can see. I have bad performance using my dashboard on wp-admin, too. And I have used

    different computers on different locations to access it but it is always slow.

    I need your help in order to know the cause of this problem.

    I have the Blog pdm.com.co running on WordPress 3.5.1
    Site Address: http://pdm.com.co/
    WordPress Address is on a subdirectory below pdm.com.co

    I have 27 pages, 55 posts, 10 categories, 317 tags.
    Theme Twenty Twelve with 17 widgets. I use Permalinks
    My Front Page on WordPress shows the latest 10 posts, each one shows a summary.

    Plugins (with latest versions):
    Better WordPress Recent Comments
    Easy Contact Forms
    Google Analytics for WordPress
    Image Widget
    NextScripts: Social Networks Auto-Poster
    Redirection
    SB-RSS_feed-plus
    ShareThis
    Social Media Widget
    Special Recent Posts FREE Edition
    WordPress SEO
    WP-Optimize
    WP-PageNavi
    Yet Another Related Posts Plugin

    I have my hosting running on Netfirms.com
    Platform Type: Debian
    MySQL Version:5.0.91-log
    Perl Version: 5.8.8
    Disk Usage: 7.8 GB

    I started to use WordPress for my blog last April 21st. Before I was using Microsoft FrontPage 2003 on the same hosting. It was running ok with good performance before April 21st.

    I have migrated to WordPress the majority of the pages, copyng its content to pages on WordPress. The "posts" on Frontpage were not migrated. For that reason I have 55 posts only.

    When i had the content of those pages ready, I have migrated to WordPress, using the article:
    http://codex.wordpress.org/Giving_WordPress_Its_Own_Directory
    Keeping WordPress Address on a subdirectory

    I use the plugin Redirection to manage 301 redirections and keep track of 404 errors.

    I have 60 redirections to manage the original html files, from pages on MS FrontPage, that i have deleted to go to the replacement pages on WordPress.

    All of them defined like:

    Origin URL: /software_gratuito.htm
    Target URL: /software-gratuito/
    action: passthrough

    Including the main page on my site on MS Frontpage

    Origin URL: /index.htm
    Target URL: /index.php
    action: passthrough

    I am not very skilled of this management of redirections, so if you see serious problems that are causing slowdowns, I appreciate your suggestions.

    I have made the following steps in order to try to eliminate this bad performance:

    I have deactivated all of the plugins and then try to access my site front different browsers, but the problem kept on.
    I have disabled the widgets that I think could cause it, but the problem kept on.
    I have used the plugin WP-Optimize trying to optimize my database tables, but the problem kept on.
    I have used Sucuri SiteCheck online utility http://sitecheck.sucuri.net/scanner/ trying to find malware but the security report says that there are not threats found, status Verified Clean. And the bad performance kept on.
    I have used the pingdom utility http://tools.pingdom.com/ in order to analyze my site and find bottlenecks, It was executed after midnight with low traffic

    with all plugins and widgets enabled. it shows that from 60 seconds trying to load pdm.com.co, 47.58 seconds keeps on the file http://pdm.com.co/, it shows on this one:
    DNS 79 ms
    Connect 156 ms
    Send 0 ms
    Wait 47.27 seconds
    Receive 76 ms
    Total 47.58 seconds

    The main suggestions that pingdom does are:
    Leverage browser caching
    Remove query strings from static resources ( I do not know how to verify this, but remember that it is new blog on WordPress, I just started to learn WordPress and I am not a developer)
    Specify a cache validator

    With 47 seconds trying to load my new blog I believe that these suggestions are not going to fix the main problem. But I appreciate your insights about it.

    When it says that waits for 47.27 seconds to load pdm.com.co the problem is with my hosting provider? or SQL database, or WordPress or ?

    ( I have the output of pingdom utility but I do not how to attach the 3 jpg files to this topic, for your analysis)

    I need your help in order to know where the problem is and how to fix it.

    Thank you for your help, in advance.

    Regards

  2. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    A good start will be to address markup errors: 227 Errors, 1 warning

    That is because of, mainly, a very badly edited theme. If you can switch to the unedited default theme with ALL plugins off, I will have a look at your site and suggest some improvements.

    BTW, I tried to visit your site. Even after 5 minutes some of the images were still loading, with the theme still to load.

    Never edit the WP default theme. Instead use a Child Theme for customizations.

  3. luiscarlos98
    Member
    Posted 1 year ago #

    Hi:

    Thank you for your soon answer.

    I have worked on the 227 errors, and many of them were caused by a ShareThis and Social Media Widget plugins.

    Still have 12 errors that I do not know how to fix them.

    I have enabled a Child Theme that depends on the unedited Twenty Twelve theme.

    I have deactivated all of the plugins

    I look forward to your suggestions.

    Regards,
    Luis

  4. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    I have enabled a Child Theme that depends on the unedited Twenty Twelve theme.

    Are you sure you are using a child theme? But I see the edited Twenty Twelve theme.

  5. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Please look at this report:
    http://gtmetrix.com/reports/pdm.com.co/7HHxM9tE
    Short details:
    Page load time: 111.16s
    Total page size: 270KB
    Total number of requests: 17

    Study the report and start optimizing your site.

  6. When it says that waits for 47.27 seconds to load pdm.com.co the problem is with my hosting provider?

    Load times that long are caused by the host. Find a new host: Recommended WordPress Web Hosting

  7. luiscarlos98
    Member
    Posted 1 year ago #

    Hi Khrishna and songdogtech:

    Thank you for your answers.

    Regarding the theme I have disabled, deleted and installed again the theme Twenty Twelve, with no changes in its setup. But it does not improve the speed of the site. I have disabled the plugins, too.

    I have reviewed the report generated by gtmetrix.
    The main suggestion to try is Leverage browser caching.

    I am not very skilled modifying files like .htaccess, so I decided to use W3 Total Cache to work with this type of configuration. I have followed the instructions, step by step, of the article in order to handle with this plugin.

    I have enabled and configured Browser cache and other caches and settings recommended in the mentioned article.

    At this moment I have some jpg files with short freshness lifetime: 4 hours, and the report recommended to change to a week.

    I think W3 Total Cache should fix them with the setup defined by the mentioned article, but it does not.

    I have examined the file .htaccess and it was modified by W3 Total Cache as it need it. I do not know how to fix it. I appreciate suggestions about it, because I want to do all of my side to try to solve this problem.

    songdogtech tells that load times that long are caused by the host. So, before finding a new host as you suggested, I have contacted my host, Netfirms, in order to know if they can find something on their side to solve the problem.

    So, if you have any additional suggestions to solve it, please let me know. I appreciate your help.

    Regards,
    Luis

  8. luiscarlos98
    Member
    Posted 1 year ago #

    Hi:

    I have received an answer from my host provider, as follows:

    "I'm sorry for any inconvenience this has caused you. I have checked the initial load time of your website, and also checked the traceroute results provided but I could not be able to find any slowness due to packet loss. I did not find any reason for the slowness when seeing your tracert output as it is not taking more than 1000 ms. However, the request at the end is timing out due to our ISP's firewall but there is no issue with server. Pigdom results shows there was a delay (of 21.134 secs) while the web browser waits to get data (appears to be CSS file/contents) from the server at: default.include.809d80.css pdm.com.co/BlogPDM/wp-content/cache/m…, which is not a server side issue.
    However, while I checked the server where your website located, I did not see any issues on it. Loads on it currently are very low so I do not think that is the issue. Connections on the MySQL server are also very low.
    However, since your website is database driven website, you may experience slight slowness while accessing it. But, we consider that to be a reasonable time for a database driven site in a shared-server environment where you share system resources with thousands of other customers. Therefore, you may find periodical slowness issues.
    Regardless of the cause, I am sure we can get it sorted out for you. So, I've optimized the tables in your database, increased the PHP memory and enabled zlib.output_compression in your php.ini file. Please verify it from your end."

    Slowness accesing my blog keeps the same.

    gtmetrix shows that i have to specify an expiration at least one week for the followng files:
    http://pdm.com.co/BlogPDM/wp-content/cache/minify/000000/0dec3/default.include.809d80.css (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/cache/minify/000000/0dec3/default.include.c67533.js (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/uploads/2013/05/EuropaCity-ciudad-bajo-tierra.jpg (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/uploads/2013/05/Magic-Radio.jpg (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/uploads/2013/05/MorePhone-smartphone-que-cambia-de-forma.jpg (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/uploads/2013/05/Oreja-impresa-3D-funcional-624x422.jpg (4 hours)
    http://pdm.com.co/BlogPDM/wp-content/uploads/2013/05/Sistema-de-navegacion-para-cirujanos.jpg (4 hours)
    Resources with a "?" in the URL are not cached by some proxy caching servers. Remove the query string and encode the parameters into the URL for the following resources:
    The following resources are missing a cache validator. Resources that do not specify a cache validator cannot be refreshed efficiently. Specify a Last-Modified or ETag header to enable cache validation for the following resources:

    http://fonts.googleapis.com/css?family=Open+Sans:400italic,700italic,400,700&subset=latin,latin-ext
    http://pdm.com.co/BlogPDM/wp-content/themes/twentytwelve/js/navigation.js?ver=1.0

    I couldnĀ“t find the reason why W3 Total did not do tihs work. How can I fix that?

    Regards,
    Luis

  9. luiscarlos98
    Member
    Posted 1 year ago #

    Hi:
    Just to close this topic:

    How I solved this problem:
    1. I had to re-install WordPress 3.5.1 and restore posts, pages...
    2. I had re-installed plugin W3 Total Cache
    3. I use this excellent guide to configure W3 Total Cache http://softstribe.com/wordpress/ultimate-guide-to-w3-total-cache
    4. 24 hours later ( I did not know why) everything started to run fast, and the blog loads between 2 and 6 seconds.
    No more 60 seconds to load.

    Regards,
    Luis

  10. Krishna
    Volunteer Moderator
    Posted 1 year ago #

    Glad to note that that you could solve the problem! :)

  11. Muhammad Haroon
    Member
    Posted 1 year ago #

    Hi @luiscarlos98, I'm the author of that tutorial (from softstribe.com). I'm glad that my article helped you.

Topic Closed

This topic has been closed to new replies.

About this Topic