WordPress.org

Ready to get started?Download WordPress

Forums

Link Library
[resolved] 5.7.8 Broken - can't edit and update a link (10 posts)

  1. interglobalmedia
    Member
    Posted 1 year ago #

    When I try and edit an existing link and then click on the update button, I get a white screen which freezes. The version prior to this one was working just fine. What kind of update could you have possibly made to this plugin that was supposed to make it "compatible" or "better"? It simply doesn't work.

    http://wordpress.org/extend/plugins/link-library/

  2. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the trouble. I must have missed a case in testing. I will have an updated version posted tonight.

  3. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the trouble once again. 5.7.9 resolves the issue by removing one small new element until I have the chance to dig into this issue more closely.

  4. interglobalmedia
    Member
    Posted 1 year ago #

    Thank you! I'm uploading now and will let you know how it goes.

  5. interglobalmedia
    Member
    Posted 1 year ago #

    So far, so good.

  6. interglobalmedia
    Member
    Posted 1 year ago #

    FYI, now I can edit links, but when I check the feature this link box, it doesn't work. The first link of the first alphabetical category shows up instead. So one error was fixed, and another created. Sorry...

  7. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    Just to check, in addition to setting links to be featured, you are also checking the 'List Featured Links ahead of Regular Links' option under library settings, right?

    I just tested this feature in my development environment and it worked as expected. I did fix one issue related to featured links a few days ago, but everything seems in order.

    If it still does not work, could you activate debug mode on your site and send me a link to it so I can see a bit more what is happening behind the scenes.

    Thanks,

    Yannick

  8. interglobalmedia
    Member
    Posted 1 year ago #

    Yannick:

    Interestingly enough, when I checked debug mode box, and then checked the feature this link box for a link, it worked. Coincidence maybe, don't know. We'll see how it goes. However, I still am not able to get a numerical id for link categories, only name of the link. Strange, no? I'm keeping debug mode checked, if you'd like to take a look.

    Below is the link to the links page:

    http://www.letsbsocial.com/links/

    Thanks for your help!

    Maria

  9. interglobalmedia
    Member
    Posted 1 year ago #

    Yannick:

    I have found the numerical id for categories. I misunderstood your instructions on your website, but I went in now and actually physically clicked as opposed to hovered over the category,and the id number appeared in the web browser within the link address.

    So I suppose then that things are working, right? I'm still in debug mode, fyi.

    Best regards,

    Maria

  10. Yannick Lefebvre
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Maria,

    Yes, the plugin seems to be working correctly. Indeed, one way to get the IDs is to click on the categories and look at the address bar. An even easier way is to install a plugin such as WP Show IDs ( http://wordpress.org/extend/plugins/wp-show-ids/). Then you will see the IDs right in the category list.

    Yannick

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic