WordPress.org

Ready to get started?Download WordPress

Forums

500 Internal server error -- /wp-admin only (7 posts)

  1. asewall
    Member
    Posted 4 years ago #

    Hi everyone,

    So I can't for the life of me figure out what's going on here. I just finished moving one of my domains from a godaddy economy hosting account to a deluxe account (to save some $). Essentially, the domain is just a blog http://www.url.org/blog -- and, after the transition, seems to be displaying content fine. The issue:

    When I go to log in to the wordpress admin (/blog/wp-admin) I encounter an internal server error. Stranger still, the /blog/wp-admin extension redirect not to the correct sub directory but to the primary root domain on my deluxe hosting account.

    Does any one know what might be causing this? Anyone know where the relevant line of code is on the wp-admin files?

    Thanks so much for your help.

  2. WatchCount.com
    Member
    Posted 4 years ago #

    Hmmmm.... Being that you just moved your blog, you may want to double-check things like your DNS entries, any .htaccess files, any of your host's configuration settings... Did you move the WP DB too? You must have. There'd be settings there to look at as well.

    -WCC

  3. philistymon
    Member
    Posted 3 years ago #

    I spent the weekend trying to work out why i was getting the 500 internal server error.
    Was a new site from scratch, no plugins, default theme. WordPress installed ok and was visible but i could not access any wp-admin files. I tried all the fixes in various forums to no avail. In desperation contacted the hosts, fixed straight away, i asked was there anything i could have done and heres their response
    "No, there's not, it's a problem within suhosin and latest wordpress release."
    This was WordPress 3.0.1.

  4. Cielo_del_69
    Member
    Posted 3 years ago #

    Hello,

    I am getting the same error when attempting to log in wp-admin. What's the solution? Should I contact my web hosting company? (1and1)

    Thanks!

    Gustavo
    Santa Fe, NM

  5. Cielo_del_69
    Member
    Posted 3 years ago #

    I just found a fix:

    http://lee-jones.com/blog/fix-error-500-internal-server-error/

    I tried the first solution mentioned on this link, and did not work.

    This is what worked:

    ....
    Also, if this doesn’t work for you, you could try editing or create an .htaccess if one is not already present. This will make sure that your php files will run with php5, this can be true if Apache by default is running an earlier version of php.

    Just put the following lines in the file on its own lines:

    AddType x-mapp-php5 .php
    AddHandler x-mapp-php5 .php

    Gustavo
    Santa Fe, New Mexico

  6. Ben Hutchings
    Member
    Posted 3 years ago #

    Simply adding:

    AddType x-mapp-php5 .php

    ..worked for me to. Thanks!

  7. caddyx
    Member
    Posted 3 years ago #

    Here is the issue I had and the solution that worked for me:

    I had 12 domains hosted on two different hosting accounts at GoDaddy. Today, I was suddenly unable to login to the wp-admin on any of them and was getting the 500 Internal Server Error. I hadn't made any changes and GoDaddy phone support was completely unable to help.

    Since I was unable to login and Disable plugins, I manually disabled all of my plugins by following this instruction:

    Use phpMyAdmin

    • In the table wp_options, under the option_name column (field) find the active_plugins row
    • Change the option_value field to: a:0:{}

    If you can't figure out how get around phpMyAdmin, I would imagine GoDaddy support could at least help with that.

    Another method for manually disabling plugins is described here: http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    After I disabled the plugins with this method, I was able to login to my wp-admin. I activated my plugins one at a time and logged out after each one until I found the culprit. In my case it was WordPress Mobile, but I imagine this could happen from time to time with other plugins as well.

    Hope this helps.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.