WordPress.org

Ready to get started?Download WordPress

Forums

iThemes Security (formerly Better WP Security)
500 Internal Server Error (WordPress 3.5) (8 posts)

  1. Shadow Slim
    Member
    Posted 1 year ago #

    I don't know where to start. When I installed the plugin and activated. Everything was okay. I was going thru the list of security suggestion that plugin suggested. I activated the blacklist feature and shortly after that I received this error message (my website is down):

    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@djshadowslim.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    Apache Server at djshadowslim.com Port 80

    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    I contacted my hosting provider about this issue and this was there response:

    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    I've gone ahead and disabled the Better WP Security plugin, from the strace output it was causing a logical loop inside the PHP script that has prevented the page from being properly loaded and after reaching the timeout the script was terminated and the 500 Internal Server Error has been completed.

    Unfortunately, there are issues with the plugin and WordPress 3.5 version, I would suggest to report this issue to the plugin developers.

    ----------------------------------------------------------------------
    ----------------------------------------------------------------------

    I even went ahead and open the .htaccess file and remove all of the Better WP Security coding and still no results.

    What shall I do to correct this problem. Please keep in mind that I am a novice (plain, easy and simple).

    http://wordpress.org/extend/plugins/better-wp-security/

  2. Marius84
    Member
    Posted 1 year ago #

    probably in our primary ftp folder u have other file created and generate this 500 error..its happen to me time ago but i dont remember the name can u make a screenshot of our wordpress primary ftp folder? thanks

  3. Shadow Slim
    Member
    Posted 1 year ago #

    Where is the primary ftp folder and what I am looking for?

  4. Shadow Slim
    Member
    Posted 1 year ago #

    It apparently causes problems with the site. You would need to contact the developer to see what the issue is. Here is the error message in the server logs that it caused:
    [Wed Dec 19 13:35:39 2012] [error] [client 123.123.123.123] Premature end of script headers: index.php

  5. JackClark
    Member
    Posted 1 year ago #

    Hi,

    I'm also getting a 500 internal server error since I enabled blacklisting.

    Does anyone know how to fix this?

  6. shafat
    Member
    Posted 1 year ago #

    its just a plugin error..you installed a plugin that cannot handeld by your web server :)

  7. sleeplessinDC
    Member
    Posted 1 year ago #

    I was also having problems and my host provider did the following. I can now get into my site.
    1- Disabled Better WordPress Security plugin.
    2- Renamed the .htaccess file to .htaccess.old (the one with all the BWPS code in it).
    3. Created a new .htaccess file that only has the following code in it:

    <files .htaccess>
    Order allow,deny
    Deny from all
    </files>
    
    <files readme.html>
    Order allow,deny
    Deny from all
    </files>
    
    <files readme.txt>
    Order allow,deny
    Deny from all
    </files>
    
    <files install.php>
    Order allow,deny
    Deny from all
    </files>
    
    <files wp-config.php>
    Order allow,deny
    Deny from all
    </files>
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /yourdomain.name/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /yourdomain.name/index.php [L]
    </IfModule>
    
    # END WordPress
  8. Netz
    Member
    Posted 1 year ago #

    Hi All
    I get the same error with the latest version!
    They change the way they look up IP so I lock-out myself!! and get the 500 server error!

    I dropped back to version 2.4.6
    Ver 2.4.8 is not tested properly!! according to me...

    Creating a new htaccess is only half the solution

    Funny ... but my IP is not in my "block" list (in the htaccess)
    so it must be in the BWPS files somewhere...
    For now I live with the old version!
    I just hope they get it fixed - It's a great plugin!!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic