WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 500 Internal Server Error With Go Daddy (27 posts)

  1. Kevo171
    Member
    Posted 3 years ago #

    This morning when I tried to sign into the wordpress dashboard on my site and I got the following 500 internal server error-

    "Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@supportwebsite.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.
    Apache Server at (mysitename).com Port 80"

    Just a few days ago I was able to log in successfully and I haven't changed anything since. I think that this is problem with my host, godaddy.com. I called and talked to support who was mostly stumped except to say that "this is a known issue on your server" and that "it might be fixed in a few hours".

    I've tried disabling all plugins without signing into dashboard like it says here-http://codex.wordpress.org/FAQ_Troubleshooting#How_to_deactivate_all_plugins_when_not_able_to_access_the_administrative_menus.3F

    No luck there.

    I also tried rewriting the .htaaccess file with no luck.

    Finally, I installed wordpress 3.0 to the site thinking that would fix the problem. It did not. Site is still up and running (although it is not complete yet)- Kevinschaum.com , but there is currently no way for me to access my WP-Admin dashboard without the 500 internal server error.

    Any ideas on how I can fix this? I made no changes to the site from the time that it was working perfectly to this morning when the error started. I'm thinking that this is on Go Daddy's side of things....

    This seems to have happened before as well- http://wordpress.org/support/topic/377485?replies=20

  2. James
    Happiness Engineer
    Posted 3 years ago #

    I called and talked to support who was mostly stumped except to say that "this is a known issue on your server" and that "it might be fixed in a few hours".

    You should trust their answer. Let them fix it. If it takes more than a few hours, ask them for an update on the issue.

  3. Francis Crossen
    Member
    Posted 3 years ago #

    Have you tried removing the .htaccess file altogether? Server 500 errors are often caused by syntax and other errors.

    If that doesn't work, put it back and wait for goDaddy!

  4. Inv_Trdr
    Member
    Posted 3 years ago #

    I have the same problem. GoDaddy is telling me to re-install WordPress from scratch. They did not tell me it was an error on their side. I thought it had something to do with the 2.9.2 security patch install. I tried installing 3.0 and am getting an error message in the dashboard that it has not installed correctly but will not finish the process for me.
    Thank you.

  5. Kevo171
    Member
    Posted 3 years ago #

    Still having the same issue. Tried deleting the .htaccess file altogether, but it didn't work.

    Any other suggestions? I'm not sure that Go Daddy support can really tell what is going on here.

  6. nathanmcginty
    Member
    Posted 3 years ago #

    same exact thing here!

  7. James
    Happiness Engineer
    Posted 3 years ago #

    Internal server errors are usually described in more detail in the server error log. If you have access to your server error log, generate the error, note the date and time, then immediately check the server error log for anything useful. If you don't have access to the server error log, ask your hosting provider to look for you.

  8. egogen
    Member
    Posted 3 years ago #

    I'm getting the same 500 error using godaddy, but a little different situation. I'm getting it when My domain.com is trying to load the hosted site (host.com/Domain ). If I go to host.com/domain it works fine. I'm assuming I have a mapping problem.

    The error log shows: " [Sun Jun 20 11:42:39 2010] [error] [client 70.xx.xx.x] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary. "

    guessing it would be the same error with the posters above.

  9. Kevo171
    Member
    Posted 3 years ago #

    Still no way to get into my dashboard. I have now talked to Go Daddy two more times. No known server issue this time around. Working with Go Daddy Support, I have now-

    -try getting rid of .htaccess again
    -downgrade back to 2.9.2
    -Restored to a backup from last week

    None of that has worked so far. Error logging is now enabled, which will take 1 hour to "turn on", so hopefully that will shed some light on what exactly is causing the issue.

  10. Kevo171
    Member
    Posted 3 years ago #

    Well, the error log didn't shed light on the issue.

    I have now uninstalled wordpress and I am in the process of reinstalling. This is a total shit show, and I have no idea what caused this as of yesterday. Go Daddy doesn't seem to know either, except to say at different times that...

    -It is a known issue on their side and that it will be fixed (this was yesterday)

    -This is something that they have never seen before and that it is somehow on my side. Possibly related to a plugin??? Reinstall is the only way, so get on with it.

    I'm now reinstalling....

  11. Kevo171
    Member
    Posted 3 years ago #

    Reinstalled ok, but that when I updated the wp-admin.php file to point to my backed up database where my site lives, I am getting the same error.

    The error is-

    [Sun Jun 20 18:19:58 2010] [error] [client XXX.244.2X3.6X] File does not exist: /var/chroot/home/content/45/6097845/html/feed

    What could be causing this?

    PLEASE HELP. I'm almost to the point where I am going to give up and try to start anew with my site. My site is still up and running, but I cannot access the dashboard.

    Thanks!

  12. James
    Happiness Engineer
    Posted 3 years ago #

    egogen, if you have access to your admin panel, what are the two URL values at Settings/General?

    Kevo171, that particular error simply means that your feed isn't available at /feed , which probably just means that your permalinks aren't enabled.

  13. Kevo171
    Member
    Posted 3 years ago #

    I get that error when I try to log in to my wordpress dashboard. The site is up and running, but I cannot access the dashboard.

    How can I fix this problem without being able to access my dashboard?

  14. James
    Happiness Engineer
    Posted 3 years ago #

    Try resettings your plugins. If that resolves the issue, reactivate each one individually until you find the cause.

  15. Inv_Trdr
    Member
    Posted 3 years ago #

    Looks like the problem ended when they moved me over to the new grid server from the older legacy server.

  16. kbaggs
    Member
    Posted 3 years ago #

    I resolved the following issues with my posting on the fix.

    Internal Server Error 500
    Plugins not auto installing
    Server Error 500 on plugins
    Blank screen on dashboard

    http://kevinbaggs.com/2010/04/17/fixing-500-internal-server-error-with-wordpress-and-1and1-com-hosting/

  17. bkgillman
    Member
    Posted 3 years ago #

    @Kevo171,
    Did you get the error problem resolved? If so, please share.
    I am having the identical problem trying to login into my dashboard.
    My site is also hosted w/GoDaddy.

    Thanks in advance

  18. SkytempleJason
    Member
    Posted 3 years ago #

    I had the same problem with one of my sites. It turns out that the theme InFocus has issues with Go Daddy that can be resolved by replacing the following file:

    wp-content/themes/infocus/lib/admin/tinymce/tinymce.php

    With this file (zip).

    Read more here.

  19. janjan32
    Member
    Posted 3 years ago #

    OMG! Thank you Skytemple Jason.
    I called go daddy 3 times... (least fav hosting company that a client uses) each time they really were not that helpful.
    Glad this is hopefully solved now.

  20. MikeK
    Member
    Posted 3 years ago #

    I'm actually encountering an issue with WordPress and Godaddy servers since I started using wordpress. I'm using my buddies server and any wordpress site he has on there (he's a developer) seems to run into constant 500 errors so its not attributed to a specific plugin. GoDaddy does not have an answer upon calling and it seems they'd prefer us to just leave Godaddy than to actually help find a solution.

    The best thing I could do to "somewhat" remedy the problem was to use Super Cache. It has nothing to do with the volume as weekends on my site are almost non-existent volume yet the errors still the same.

    Anyone find any solutions?

    Thanks,
    Mike

    Website

  21. etellewyn
    Member
    Posted 3 years ago #

    I'm coming in pretty late to the game but just found this thread today and wanted chime in to say that I am also having this issue with Godaddy. I have a couple different (unrelated) client sites and all have intermittent 500 server error problems on godaddy. (interestingly they usually have them at the same time, this is why I am sure it's their problem) I don't do anything to cause it and it also resolves by itself (until next time).

  22. XRint
    Member
    Posted 3 years ago #

    Try to change the server response code from 500 to 200 in wp-includes/functions.php.

    See it here http://extremeresults.biz/2011/02/error-500-internal-server-error-while-posting-a-comment-in-wordpress/

  23. arch1
    Member
    Posted 3 years ago #

    I have also been having the same problem with Go Daddy. My blog has been down since Thursday. intially I messed about with URL name change in general settings. I wanted original URL back and went into Manage via phpMyAdmin changed back to original address in options and pressed Go.

    However I got "Internal Server Error

    I checked error logs and got this message

    line 1: host: command not found

    [Fri Feb 11 00:27:52 2011] [error] [client 209.85.238.215] Premature end of script headers: /var/chroot/home/content/a/r/c/archoni/html/blog/index.phpZend Optimizer requires Zend Engine API version 20021010.The Zend Engine API version 20050606 which is installed, is newer.Contact Zend Technologies at ww.zend.com/ for a later version of Zend Optimizer.

    [Fri Feb 11 00:28:37 2011] [error] [client 114.111.95.132] File does not exist: /var/chroot/home/content/a/r/c/archoni/html/robots.txtZend Optimizer requires Zend Engine API version 20021010.The Zend Engine API version 20050606 which is installed, is newer.Contact Zend Technologies at ww.zend.com/ for a later version of Zend Optimizer.

    my hosting support says to get older version..but they still have not sent me one..

    someone suggested I try Turn off 'Zend' add following line in .htaccess file.

    php_value zend_optimizer.optimization_level = 0

    I tried this but got blank page.

    I cannot get onto my admin even

    Anymore suggestions?

  24. etellewyn
    Member
    Posted 3 years ago #

    In our case the 500 error was only intermittent and was occurring along with slloooowwww speeds. So we upgraded to their "4G" hosting which made it worse at first but then completely solved the problem.

    We have since ended up with two conclusions regarding this error...
    1) in our case it was at least in part related to bandwidth, and 2) it is also related to the .htaccess file.

    When we first moved to the 4G host, everything broke completely with a 500 error and this was due to the .htaccess file. It seems that their 4G host doesn't handle these the same as their shared hosting server does. I know almost nothing about .htaccess so I don't know what the offending command was, but removing the .htaccess file completely resolved the issue (and of course resulted in other file not found issues! so if you know how to read/write .htaccess you'll have a better time navigating this than we did)

    2) since moving to the 4G hosting, WordPress is LIGHTNING FAST and the 500 errors have stopped. I have seriously never had it respond this fast (even in admin) on any other host. it's amazing. To be honest I was secretly hoping to move to a different host because I don't like Godaddy as a company, but this 4G/grid hosting thing is now faster than any other host I currently work with so I am going to stay at least until I find another that is as fast!

  25. Gayatriom
    Member
    Posted 3 years ago #

    Hey!
    So the 4G plan is a virtual dedicated server right?!

  26. MMMemories
    Member
    Posted 3 years ago #

    So, am I to assume this is an issue that will eventually resolve itself? I'm really new to this and kind of confused.

    I JUST got my WP uploaded and up and running this morning, working in the dashboard with no problems. I uploaded a new Theme I purchased to my server (hosted by Laughing Squid, not Go Daddy), then immediately after I couldn't do anything. I hadn't tried to install it or anything, just uploaded into my directory. I got this message next time I clicked on my dashboard:

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    I can't figure out how to get back to my Dashboard, and putting my url into my browser gives me the same thing.

    Is there anything I can do, or should I just wait it out?

    Thanks for your help.

  27. etellewyn
    Member
    Posted 3 years ago #

    Gayatriom: no the 4G hosting is not dedicated, it's still shared. I don't know the technical details about the actual configuration except that it's spread across multiple servers so that when one is slow or goes down, it does not impact the performance.

    MMMemories: This sounds like a problem with your theme. I would go in via FTP and manually remove that theme from your wp-content/themes folder. As I said, in our case the 500 errors happened from two causes: One was intermittent due to slow server (fixed by switching hosting package), and the other was more serious, due to an .htaccess misconfiguration. You seem to have a more serious type!

    Good luck to you!

Topic Closed

This topic has been closed to new replies.

About this Topic