WordPress.org

Ready to get started?Download WordPress

Forums

WooCommerce - excelling eCommerce
500 Internal Server Error when Adding to Cart with Internet Explorer (8 posts)

  1. alanfang5
    Member
    Posted 6 months ago #

    I get a 500 internal server error when attempting to add a product to my cart in internet explorer 9. My Woocommerce install is currently set to automatically redirect users to checkout when they add an item to their cart. This error only appears in Internet Explorer, add to cart works fine in Chrome Firefox etc.

    I've tried increasing my memory limit as suggested in this thread: http://wordpress.org/support/topic/plugin-woocommerce-excelling-ecommerce-update-the-new-version-a-few-hours-ago-got-the-500-internal-error-htaccess?replies=4 but that did nothing. Anyone have any idea what the problem could be?

    http://wordpress.org/plugins/woocommerce/

  2. alanfang5
    Member
    Posted 6 months ago #

    Correction, the problem is actually only limited to Internet Explorer 10. I came across this page: http://docs.woothemes.com/document/ajax-problems-windows-7-8-internet-explorer-10/ which seems to explain the problem I'm having.

    Does anyone have a workaround for this until this bug is fixed in Internet Explorer? I've found many other posts from users with the same problem but not solution.

  3. alanfang5
    Member
    Posted 6 months ago #

    Does anyone have any possible thoughts as to how to fix this? I've had a large numbers of customers complain that they can't make an order and have been trying for days to find a solution to this.

  4. varktech.com
    Member
    Posted 6 months ago #

    hi,
    The woo article indicates that no solution yet exists... you might detect for ie10 and throw up a message stating add to cart issues, need to move to a dif browser (at least until MS comes up with a fix).

  5. alanfang5
    Member
    Posted 6 months ago #

    That's what I was afraid of. It just seems insane that all Internet Explorer 10/11 users are totally unable to place orders in stores using WooCommerce. Really unfortunate.

  6. Eccola
    Member
    Posted 6 months ago #

    Hello everyone,

    We were struggling with the same issue last year, with every IE version.
    It was actually Woothemes support team who finally pinpointed the issue
    was caused by mod_security. Badly configured mod_security, that is.

    So, check if your (apache) server is running mod_security, and try disabling it completely in .htaccess:


    <IfModule mod_security.c>
    SecFilterEngine Off
    </IfModule>

    That really did it. MS never will.

  7. alanfang5
    Member
    Posted 6 months ago #

    Hi Eccola, thank you so much for your reply. Disabling mod security fixed the problem for me instantly. My server is running mod_security 2 so I had to use this guide to disable it rather than doing it in .htaccess: http://www.inmotionhosting.com/support/website/modsecurity/disable-modsecurity-for-a-domain Thank you for again for all the help.

  8. Eccola
    Member
    Posted 6 months ago #

    Hello alanfang5,

    you're welcome, I'm glad this "fix" worked for you!

Reply

You must log in to post.

About this Plugin

About this Topic