WordPress.org

Ready to get started?Download WordPress

Forums

500 Internal Server error showing at instalation in Go Daddy server (67 posts)

  1. kaushiktwcs
    Member
    Posted 5 years ago #

    I am trying to install a fresh worderpress 2.7 in godaddy server. It is just a fresh copy, downloaded and unzipped. I have uploaded it to the server through ftp and then trying to install that. But whenever i am calling through url it is giving an 500 Internal server error. After some googling I got some related problems solved by wp-cache. But i cant find any file like that in total folder. Can any one please help me!!!

  2. Samuel B
    moderator
    Posted 5 years ago #

    if you are on a windows server you will need to switch it to linux in your hosting control panel

  3. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    A 500 internal server error can mean a few things. It's best if we take a look. What's the domain name?

  4. kaushiktwcs
    Member
    Posted 5 years ago #

    you can find it on TEst Blog
    . We are using this domain for testing. It is a windows server. Is this a fixed problem, that wordpress cant be installed at any windows server?

  5. Samuel B
    moderator
    Posted 5 years ago #

    Is this a fixed problem, that wordpress cant be installed at any windows server?

    I understand wordpress runs fine on dedicated windows servers. It will not run well on the shared servers. This has been an ongoing thing with godaddy since I've been doing installs - like 3 years.
    Sometimes you can actually get it to install but then the problems start. Most times it won't install at all.

  6. kaushiktwcs
    Member
    Posted 5 years ago #

    Well, the last update is that, we are able to install it through gtodaddy's application installation. Godaddy gives 50 more apps for direct installation from 'My Application' tab.
    But the problem is not resolved yet. Why the direct install works? And why not from ftp.

  7. kaushiktwcs
    Member
    Posted 5 years ago #

    Thanks samboll. But can you please say what is the actual problem?

  8. Samuel B
    moderator
    Posted 5 years ago #

    just guessing but the servers are not properly configured as the install will work on most hosts

  9. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    We have been trying to get in touch with you to discuss this further. Please be on the lookout for an email from the GoDaddy hosting group.

  10. Samuel B
    moderator
    Posted 5 years ago #

    @ GDHosting
    can you make a definitive statement about the windows servers at GoDaddy?

  11. aberean
    Member
    Posted 5 years ago #

    I just wanted to say, Although I am becomming more and more a "non-fan" of godaddy, I have been running WP for about 2 years on godaddy with windows hosting. it took a little tweaking, but it worked! I just upgraded to linux with godaddy and installed WPMU and it works great. am using shared hosting even. only draw back so far is am not able to automattically add new blogs thru MU with subdomains.

  12. Samuel B
    moderator
    Posted 5 years ago #

    I have been running WP for about 2 years on godaddy with windows hosting.

    was this on a shared server?
    and how much tweaking?

  13. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    @ samboll
    I'm interested to learn about your experience with Windows servers at GoDaddy. Any details you provide will help us out! Please email the information to hosting@godaddy.com.

  14. Nemiard
    Member
    Posted 5 years ago #

    Im having similar issues. After uploading the files via FTP, I get either the 500 error or I just cant see the files all together. It doesn't make sence to me, as I should still be able to view the files when looking at folders through a webbrowser. Is there some sort of read-only settings that I need to change?

    Files which I create and folders that arnt associated to wordpress upload and also view fine. But the moment I add a filefolder from WordPress, the folder views as empty when I refresh the page in a browser??

  15. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    @ Nemiard
    I'd be happy to check it out. We'll need approximate times that the 500 errors occur so that we can review the server logs. You're welcome to send an email with the domain name and the any other details.

  16. enlaceflorida
    Member
    Posted 5 years ago #

    I have a similar problem
    I have installed wordpress.org version 2.7.1 on godaddy.
    When I try to post a comment without being logged in, I get the 403 server error message i.e
    " 403 - Forbidden: Access is denied.
    You do not have permission to view this directory or page using the credentials that you supplied"
    or the 500 server error message i.e
    " 500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed".
    And the strange thing is I don't get it the first time I post the comment without being logged in but I get it from the second time.

    I think this is a server authentication issue - I tried several things to fix this.
    1) I enabled anonymous authentication on the IIS settings on the godaddy hosting control center but that didn't work.
    2) I tried the .htaccess file (which seemed to have resolved 403 errors in many cases)but in vain.
    3) I tried to fix it at the code level but couldn't do it.

    @GDHosting
    could you give any suggestions as to what i can do to resolve this

    The url of my blog is
    http://collegegoalsundayflorida.org/wordpress/

  17. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    @enlaceflorida
    I've got our development group looking in to this. We'll be in touch with some more information soon. Thanks!

  18. bennihan
    Member
    Posted 5 years ago #

    I am having the same exact problem with Godaddy glad that I found this forum. 500 Internal Server error comes up often when trying to do simple things. I haven't done any editing to anything that I've installed on my wordpress site for it to be going wrong often. I e-mailed godaddy and they pretty much told me that it was my own problem and not theirs.

    I'm currently running on a shared windows server and will be taking all of my business away from godaddy if this problem is not resolved soon. If you can show me what is wrong my site is http://www.baltimoresushiblog.com

  19. webgirl
    Member
    Posted 5 years ago #

    Are you using Godaddy hosting type IIS 7 and PHP 5.x? If not you may need to switch and have your account transferred to it since I have read a discussion about PHP 4 and IIS 6.0 issues with WordPress which seems to have been fixed when using IIS7 and PHP5 on Godaddy. The only reason you would be using IIS 6 is to use Coldfusion or FrontPage Extensions.

  20. jennsweb
    Member
    Posted 5 years ago #

    I am also receiving the Error 500 message after the site was 1) installed via Godaddy's automatic install 2 weeks ago and 2) the site was fully up and running as of 2 days ago (last time checked). Windows hosting as well.

  21. jennsweb
    Member
    Posted 5 years ago #

    So, site is working now. I'm still nervous about the hosting config though. I hope switching from Windows to Linux won't be an "upsell-related issue".

    Thanks for all the useful info here!

  22. Go Daddy
    Go Daddy Support
    Posted 5 years ago #

    You can use an IIS 7 account at Go Daddy to install WordPress. You can upgrade to IIS 7 if you're currently on an IIS 6 account by using these instructions: http://help.godaddy.com/topic/623/article/4138

    If you'd rather switch from Windows to Linux there is no charge. To make the switch you can follow these steps: http://help.godaddy.com/article/1285

    Alternatively, you can call our 24/7 support staff at 480.505.8877 and they can assist you with either process.

  23. wpuser001
    Member
    Posted 4 years ago #

    Let me add to the growing count of "500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed." :)

    I have Shared Windows Hosting Account running IIS 7 and I have been trying to install and run wordpress manually under my secondary domains, but for some unknown reason it just won’t run and godaddy is not keen on supporting this issues either, so on the advise of godaddy support staff, I am here; in the open …in the forum.

    Plz Help!

    If any one here knows how to make wordpress work under secondary domains, running windows hosting IIS 7 than please let me hear from you…. I am in no mood to upgrade / downgrade my hosting plan… just few months ago I upgraded from IIS 6 to II7 on the advise of godaddy… and I don’t want to follow this rule: if you need something, you either need to upgrade / downgrade …its too much of trouble …..

    wordpress enthusiast.

  24. enlaceflorida
    Member
    Posted 4 years ago #

    hosting the wordpress blog on linux hosting of godaddy will resolve the issue

  25. globalartwork
    Member
    Posted 4 years ago #

    I got round this by installing the wp-supercache module at the recommendation of the Godaddy tech guys. It did work, but its a bit fiddly.

    You are right, hosting on linux will solve it, but some people need windows hosting too (I also run asp.net apps)

    The first problem I had was I couldnt even access my site to install the plugin, but eventually after a few refreshes it worked. Basically I did this:

    * Download plugin from http://wordpress.org/extend/plugins/wp-super-cache/

    * Extract the files and upload them to your wp-content folder

    * go into your godaddy hosting account. Under content, go to file manager.

    * Check the box next to wp-content and click permissions. Uncheck inherit and check Read and Write. Click ok (Yeah I know not good to make this writable, but its only temporary)

    * Go back to your wordpress plugins page and enable the plugin.

    * Next, go back into your file manager and go to wp-content/cache. Make this folder read and write too.

    * Next, edit your wp-config.php file in your ftp editor and add

    define('WP_CACHE', true);

    near the top of your file. I put it after the db collate define section.

    * Now visit the settings page of the plugin and turn the status ON. You can only do this when wp-config is writable, which is why we did that. Save the page settings.

    * Now go back into the file manager and make the wp-config directory inherit.

    * Hit your site and you will see the pages start to get cached.

    They should now get served faster and be able to take a Digging.

    Hope that helps someone - Im with enlaceflorida though in that if you can, maybe linux hosting is more appropriate until Godaddy sort this.

  26. halytech
    Member
    Posted 4 years ago #

    Ok I am using Linux Shared hosting but found a round-about resolution to this issue.

    I was getting 500 errors and their support was pretty useless, but I persisted and EVENTUALLY, they informed me that the problem was I was using FastCGI associated with my PHP files.

    It comes this way BY DEFAULT.

    I went into their Hosting GUI, the Extensions stuff, and changed the file association for PHP files from "FastCGI PHP 5.x" to just "PHP 5.x"

    Even though there is really NOTHING in any of their sales information that says you CAN'T use this, it was on anyways.

    I don't get any 500 errors any longer and my response time seems much faster across the board.

    Hope this helps.

  27. Go Daddy
    Go Daddy Support
    Posted 4 years ago #

    @globalartwork and @halytech
    Thanks for the info!

    I would like to clarify a little. Like halytech mentioned, FastCGI is enabled by default. Normally, this is best because FastCGI is faster than PHP alone. However, it can be more susceptible to server errors with modules or plugins that are not coded correctly.

    @lca7
    Is your site hosted with Go Daddy?

  28. lca7
    Member
    Posted 4 years ago #

    I'm now using hostmonster,it runs ok,and when it use godaddy,it said:
    500 - Internal server error.
    There is a problem with the resource you are looking for, and it cannot be displayed.
    You can see it here:
    http://11lx.com/mozilaus/

  29. halytech
    Member
    Posted 4 years ago #

    @Ica7

    I had trouble tracking it down until I turned on error logging and found the server error logs (which had lines very specific to issues with FastCGI).

    Could you find or post those error logs? And, as GDHosting stated, are you using GoDaddy for your hosting?

  30. jockpost
    Member
    Posted 4 years ago #

    I have been getting the 500 Internal Server error occasionally when editing or refreshing the admin panel. (GoDaddy hosting, Linux)

    I tried changing "FastCGI PHP 5.x" to just "PHP 5.x" per halytech's suggestion. If the problem keeps happening I'll let you all know.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Topic