WordPress.org

Ready to get started?Download WordPress

Forums

500 Internal Server error on css,js files on 3.5 RC3 (3 posts)

  1. lightnb
    Member
    Posted 1 year ago #

    I'm testing MS in 3.5 RC3. On a test site, "test1" at URL http://www.site.com/wpsa/test1/, the site loads, but the js and css files do not. The js and css files produce 500 Internal Server Errors.

    WordPress is installed in the folder /wpsa.

    Example URL with 500 error:
    http://www.site.com/wpsa/test1/wp-includes/css/admin-bar.min.css?ver=3.5-RC3

    RewriteRules, per instructions:

    RewriteEngine On
    RewriteBase /wpsa/
    RewriteRule ^index\.php$ - [L]
    
    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) WordPress/$2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ WordPress/$2 [L]
    RewriteRule . index.php [L]

    Apache Log:

    [Wed Dec 05 00:52:25 2012] [debug] core.c(3063): [client ip.ad.ad.ress] r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/WordPress/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/
    [Wed Dec 05 00:52:25 2012] [debug] core.c(3069): [client ip.ad.ad.ress] redirected from r->uri = /wpsa/test1/wp-content/themes/twentytwelve/js/navigation.js, referer: http://www.site.com/wpsa/test1/

    Possible bug or misconfiguration?

  2. lightnb
    Member
    Posted 1 year ago #

    I just tried a fresh install from the beginning and still have the same issue. The "main" site at http://www.site.com/wpsa/ loads fine, the sub sites at http://www.site.com/wpsa/anything-else, load the page but not the JS or CSS files.

  3. Moving to the alpha/beta forum.

    Did you set your allowOverride to include 'All' in your httpd.conf file?

Topic Closed

This topic has been closed to new replies.

About this Topic