WordPress.org

Ready to get started?Download WordPress

Forums

500 Internal server error on a fresh WP install (7 posts)

  1. Jonathan Graft
    Member
    Posted 2 years ago #

    I feel it would be most helpful if I explained the backstory...

    The company I work for owns a server but it wasn't running PHP or MySQL. So we spent some of Friday working on that and I thought we had it up and running 100%. I then installed a fresh new copy of WordPress.

    However, when I try to upload a media file (not the multi-file uploader) or when I try to install/upload a plug-in, I receive a 500 Internal server error. When I try to upload a media file using the multi-file uploader I receive a small block of text that says "HTTP Error". I believe this is also breaking my TimThumb.php file necessary for my current theme. I currently have this exact same theme installed on 2 different servers and have not encountered this problem which leads me to believe we did something incorrect on the server during install.

    I did some research and read about permissions. I checked the permissions and everything within the WordPress directory is listed as 755. I currently don't have access to the .htaccess file nor the server error log, but I might be able to if I ask the IT department.

    Also, I am unsure if this is related or not...but I have the Fast Secure Contact Form plug-in installed (I was able to do this by downloading the ZIP manually and dropped it in the correct folder using an FTP app). Within the settings for the plug-in, I am receiving this error message:
    There is a problem with the directory /captcha/temp/. The directory Unwritable (fix permissions). Permissions are: 0777 Fixing this may require assigning 0755 permissions or higher (e.g. 0777 on some hosts. Try 0755 first, because 0777 is sometimes too much and will not work.) Fixing the actual problem is recommended, but you can uncheck this setting on the contact form options page: "Use CAPTCHA without PHP session" and the captcha will work this way just fine (as long as PHP sessions are working).
    I checked said folder and it was listed as 755, not 777 as it states.

    I would appreciate any and all help! Thank you all!

  2. The company I work for owns a server.... which leads me to believe we did something incorrect on the server during install..... I currently don't have access to the .htaccess file nor the server error log, but I might be able to if I ask the IT department.

    This is really a server admin problem and is far too complex to diagnose here because of the number of variables. It can be permissions problem, file/folder web and apache ownerships, the way php was built and configured, etc. You really need to work with your IT department.

  3. Jonathan Graft
    Member
    Posted 2 years ago #

    Thank you songdogtech. I am going to try to sit down with them sometime soon to see what we can come up with.

    I have posted a screencast of the problem I am encountering here. I don't know if this will help solve my problem or not but I figured I may as well include it.

    *PS Ignore the foul language in the bottom left hand corner...I had iTunes playing a song and completely forgot about it! :-P

  4. Jonathan Graft
    Member
    Posted 2 years ago #

    Could running an older version of PHP cause this problem? I believe we are running 5.3.6 while I read the latest version is 5.4.3. I just briefly talked it over with a team member and we can't figure out the problem.

  5. This is still a server admin problem; and you're delaing with mutiple issues at the same time. I'd try http://serverfault.com/

    And see http://wordpress.org/about/requirements/

  6. Jonathan Graft
    Member
    Posted 2 years ago #

    I think tomorrow I am going to try installing a fresh copy of WordPress. Last time we installed each piece one by one (PHP, MySQL, phpMyAdmin, etc.) but I think this time we are going to try using WebPI (Microsoft Web Platform Installer). I'll post back tomorrow regardless if it works or not.

  7. Jonathan Graft
    Member
    Posted 2 years ago #

    Well, turns out I was encountering two separate problems. I figured out that the reason for the images not properly loading was because of the following error in TimThumb.php:
    GD Library Error: imagecreatetruecolor does not exist - please contact your webhost and ask them to install the GD library

    However, the 500 internal error is still there. We did not try re-installing using WebPI (maybe some other time). Luckily I can manually upload anything I need, so this will do for now. Although I will come back to this problem and try to fix it at a later date.

Topic Closed

This topic has been closed to new replies.

About this Topic