WordPress.org

Ready to get started?Download WordPress

Forums

500 Internal Server Error from Permalink change (19 posts)

  1. bjraybould
    Member
    Posted 9 years ago #

    I installed wordpress using fantastico and everything worked fine until I tried to change the permalink setting. I wanted to have a file name that consists of the category name followed by topic name. I must have misinterpreted the syntax and whatever I typed in has caused me to get a 500 Internal Server error when I try to get into the admin or the blog.

    The entry in my server error log (in cPanel) is [Fri Mar 18 17:49:37 2005] [alert] [client 67.174.193.147] /home/virtua38/public_html/blog/.htaccess: RewriteRule: bad flag delimiters

    I cannot figure out from the comments in this forum which file I need to edit to fix the problem. It sounds like it might be something wrong in the htaccess file, but I have no idea what to change in it . Any ideas anyone? Any help is much appreciated.
    thanks
    Barry

    [Moderated: .htaccess contents removed - please paste to a text file and post on your site and link to it.]

  2. NuclearMoose
    Member
    Posted 9 years ago #

    Have WordPress regenerate the permalink code for you and then copy/paste it into a fresh .htacess file. Maybe you have leftovers from the previous version that are causing you grief.

  3. bjraybould
    Member
    Posted 9 years ago #

    Thanks for your reply. How can I get wordpress to regenerate the permalink code? When I try to access the top level blog directory, or the blog/wp-admin directory, I get the server error message.
    Thanks
    Barry

  4. NuclearMoose
    Member
    Posted 9 years ago #

    Barry,
    Can you login to your admin panel? In your browser, navigate to http://yoursite.com/wp-login.php and that should take you to your admin panel. Once there you can go to your OPTIONS menu and select PERMALINKS and regenerate them there.

  5. chaos
    Member
    Posted 9 years ago #

    what if I can't login to my admin panel?? I also deleted the values in 'permalink_structure' in the wp_options table of the db, but the 500 error is always there...

  6. Delete the .htaccess file.

  7. chaos
    Member
    Posted 9 years ago #

    this is the worst of all: i don't have any .htaccess file !!

  8. .htaccess is a hidden (invisible) file. Is your FTP app set to show hidden files?

  9. chaos
    Member
    Posted 9 years ago #

    i think so. i've tried with 2 apps. not only the .htaccess is not there, i can't create it with none of the apps

  10. This tutorial will teach you how to show hidden files in most popular Windows FTP clients. Please double-check yourself against it: http://www.tamba2.org.uk/wordpress/ftp/

  11. chaos
    Member
    Posted 9 years ago #

    Ok, thanks macmanx, this tutorial is great!

    now i'm trying with leechFTP, but my server is don't give me the permissions to do that:

    > DELE .htaccess
    < 550 .htaccess: Forbidden filename

  12. chaos
    Member
    Posted 9 years ago #

    ah!! but I can RENAME the dir!!! oh yeah!!

    thankiou macmanx!!

  13. It looks like your server doesn't want you to use .htaccess. If I were you, I'd ask them to give you permanent full access. If they don't, there are plenty of great hosts out there who do, and moving WordPress is very easy. http://www.tamba2.org.uk/wordpress/move/

  14. citizenofnowhere
    Member
    Posted 9 years ago #

    Help!! How do I change the permalinks back to what they used to be? I ran the update to this structure /%postname% but i got the 500 error.

    the links, however, WERE renamed. when I delete the .htaccess file nothing changes. I can log into the control panel, but I can't open any of the pages or comments, and when I try to clear the structure box in options-permalink.php i get the same 500 error!!

  15. citizenofnowhere
    Member
    Posted 9 years ago #

    have erased everything and reinstalled a clean wordpress

    still get the 500 internal server error!!!

  16. citizenofnowhere
    Member
    Posted 9 years ago #

    now the best part... at one point after everything went haywire i tried re-writing the links to /index.php/%postname% and that works!

  17. citizenofnowhere
    Member
    Posted 9 years ago #

    if anyone else has this problem, look in your database in wp_options option id number 40 is the permalink structure. check to see if that has updated. mine wasn't that's why i got the problem

  18. choosechris
    Member
    Posted 9 years ago #

    HELP! I made the terrible mistake of changing my permalink structure, and now I'm getting the "500 Internal Server Error". I can't access anything, including the control panel. I've tried everything I could think of, including deleting the .htaccess file, uploading all of my WordPress files again, and I even logged onto my server and used the PHP manager utility to access the wp_options file and tried changing line 40 to something that will work. But I am still getting the "Internal Server Error". Can anyone help me? Is there anything I can do to get my blog back?

  19. choosechris
    Member
    Posted 9 years ago #

    Please disregard my request for help. I deleted the entire database, deleted all of the files on my server, and started completely from scratch. I lost a half-dozen posts in the process, but I had already started to redirect traffic from my old site and I needed to get it back in working order in a hurry. Fortunately I had the CSS theme I created so it didn't take me more than 90 minutes to reinstall WordPress, re-upload all of my files, re-configure my settings, and type out a post. This is a TERRIBLE bug in WordPress that needs to be fixed right away. All of my problems started when I tried to change the structure of my permalink. As soon as I clicked the "Save" button, I got the "500 Internal Server Error" page. It took me almost three hours of attempts to fix it before I decided to just delete everything and start over from scratch. I still don't know how to fix this without deleting everything, but I think that the problem resided in line 40 of the wp_options file in the database that deals with the permalink. However, if that is the problem, I have no idea what would need to be done to fix it. WordPress is too wonderful to have such a fatal flaw as this. Hopefully it will be fixed very soon!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.