WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 500 Internal Error (7 posts)

  1. Lassirra
    Member
    Posted 6 years ago #

    Hi there

    Yesterday, my site began generating the following error when attempting to visit my site:

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@thehuntersmark.net and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.37 Server at thehuntersmark.net Port 80

    The error log says:

    [Wed Aug 13 04:39:35 2008] [alert] [client xx.xxx.xx.xxx] /home/xxxxxx/public_html/.htaccess: Invalid command 'ReRewriteCond', perhaps mis-spelled or defined by a module not included in the server configuration

    The site had been working fine for months before yesterday, and I made no changes whatsoever to the site yesterday, or any time recently, so I'm not sure what changed to generate this error.

    The contents of my .htaccess file:

    AddHandler x-httpd-<IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    ReRewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Any help anyone could provide would be greatly appreciated. I attempted contacting my web host's Tech Support, but they were distinctly not helpful in the slightest.

  2. Lassirra
    Member
    Posted 6 years ago #

    I corrected the "typo" on line 4:
    ReRewriteCond %{REQUEST_FILENAME} !-f
    To:
    RewriteCond %{REQUEST_FILENAME} !-f

    And still experience the error described above.

  3. whooami
    Member
    Posted 6 years ago #

    START by removing the duplicate entries.

    You need ONE of these:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    and then fix this:

    AddHandler x-httpd-<IfModule mod_rewrite.c>

    That line is incomplete

    It should read something like one of these:

    AddHandler x-httpd-php5 .php

    OR

    AddHandler x-httpd-php php

    Then notice you also have this:

    f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    THATS your error.

    If you remove the fucked up ones, and leave one glob that is formatted properly, and fix that other thing, you'll fix it.

  4. Lassirra
    Member
    Posted 6 years ago #

    As per my host's instructions, I actually removed the following line altogether:
    AddHandler x-httpd-<IfModule mod_rewrite.c>
    And deleted the duplicate entries (though I'm not sure where the duplicate entries came from in the first place--I've never modified the .htaccess file manually).
    I did notice the f and had already removed it, after running the .htaccess file through a validator (http://www.lyxx.com/freestuff/002.html).

    I had actually tried all those things previously and had still been experiencing the 500 error. After fiddling with it for a while, I tried again, and it actually worked, so I'm not sure what else may have changed.

    Thanks for the help (though I could've lived without the profanity).

  5. tgiokdi
    Member
    Posted 5 years ago #

    Me too, my eyes are very precious, and I would never expect that kind of talk on the internet!

    My goodness!

  6. Leone Venticinque
    Member
    Posted 5 years ago #

    Hi to alls,
    Me too in same problem:
    few days ago update to 2.7.1, all works fine, I write new post and so on.

    Today, a bad message opening the site:

    ----------------------
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, support@freehostia.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache/1.3.33 Server at storiaduepuntozero.freehostia.com Port 80
    ----------------------

    Freehostia.com help told me that WordPress is the cause. So with Google I find some solutions: changing all permission for files and folders to 755 (tried: the problem remain the same); changing all permission for files to 644 and for folders to 755 (tried: the problem remains the same); cancel .htaccess (tried: the problem remains the same); renaming "plugin" folder (tried: the page is totally blank).

    Please can you help me? The site is http://storiaduepuntozero.freehostia.com

    Thanks in advance...

  7. sfmobius
    Member
    Posted 5 years ago #

    ountered in order over the span of about 3 months.

    1) Live Writer returned the "500 error" anytime I tried to upload a post with pictures or attachments. I incorrectly assumed it was my xmlrpc file.
    2) Dashboard widgets would sometimes load and other times only 1 or 2 would load.
    3) Manually creating posts in WP would generate "500 error" but the post still went thru.
    4) Unable to upload any media files thru WP.

    My ISP proposed a variety of answers so I thought I'd share all of them. This is, of course, assuming your write permissions are set correctly for your WP directory.

    1) Disable and test plug-ins. This is particularly important if you use plugins that restrict views or categories based on users logged in or not. Sometimes, they create their own .htaccess files which causes problems if you upgrade, downgrade, or remove the plugin. You should have one .htaccess file in your root blog directory. Any others in other sub directories should be suspect. Check the plugin vendors instructions for a fix.

    2) The file upload size for your server is set too low and the 500 error is returned as a result. Your host can change this if you don't know how. It takes all of 5 minutes. I didn't realize my host has a default setting of 10megs.

    3) If your hosting provider is running multiple versions of PHP, you'll definitely need this fix for WP v2.7 and above. Your .htaccess file has to call for the newer version of PHP.

    Note - If you are using default permalinks, you may not have a .htaccess file at all. WP only creates it when you change the default handling of how it processes files/links. You'll have to manually create one in this instance. http://codex.wordpress.org/Using_Permalinks

    Use "AddType x-mapp-php5 .php" without the quotes and note the spacing between the 5 and the dot is correct, do not remove it. Also, add this to your .htaccess file AT THE VERY BEGINNING, even before the "#Begin WordPress" comment.

    Apparently, PHP v5.0 has significant improvements in rendering w/o extra server load so ISP's may throttle your backend use to encourage you to upgrade. NOTE - If your host is only using one version of PHP, DON'T DO THIS, IT WILL CAUSE MORE PROBLEMS.

    *I've posted this on a few different threads, apologies if you get this more than once*

Topic Closed

This topic has been closed to new replies.

About this Topic