WordPress.org

Ready to get started?Download WordPress

Forums

[closed] 500 error on wp-admin after 3.4.2 update (7 posts)

  1. mctaguma
    Member
    Posted 1 year ago #

    Hi all,

    After the WordPress 3.4.1 to 3.4.2 update, the site seemed to work fine, but now we have discovered that the wp-admin directory of the main site is returning an HTTP 500 Internal Server Error.

    URL is http://langwoodsphotography.co.nz/wp-admin

    Looking at the error log, the issue appears to be happening in sunrise.php, error log posted below:

    [20-Sep-2012 23:20:00] PHP Warning: include_once(/home1/langwood/public_html/wp-content/sunrise.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home1/langwood/public_html/wp-includes/ms-settings.php on line 18
    [20-Sep-2012 23:20:00] PHP Warning: include_once() [<a href='function.include'>function.include</a>]: Failed opening '/home1/langwood/public_html/wp-content/sunrise.php' for inclusion (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/share/pear') in /home1/langwood/public_html/wp-includes/ms-settings.php on line 18
    [20-Sep-2012 23:20:03] PHP Warning: include_once(/home1/langwood/public_html/wp-content/sunrise.php) [<a href='function.include-once'>function.include-once</a>]: failed to open stream: No such file or directory in /home1/langwood/public_html/wp-includes/ms-settings.php on line 18
    [20-Sep-2012 23:20:03] PHP Warning: include_once() [<a href='function.include'>function.include</a>]: Failed opening '/home1/langwood/public_html/wp-content/sunrise.php' for inclusion (include_path='.:/usr/lib64/php:/usr/lib/php:/usr/share/pear') in /home1/langwood/public_html/wp-includes/ms-settings.php on line 18

    We are using WordPress Multisite with WPMU Domain Mapping - this was stable before the update.

    Another site in the Multisite install is working fine : http://cameradigitalphoto.co.nz/wp-admin

    Please note that this HTTP 500 Error only occurs on the main site in the multisite install, it is not an issue on any of the other 3 sites we have.

    [ Email address moderated. Please stick to the forums for support so it can benefit everyone ]

  2. Is this file there?

    /home1/langwood/public_html/wp-includes/ms-settings.php
  3. mctaguma
    Member
    Posted 1 year ago #

    Yes it is.

    The issue has been temporaily solved by creating a php.ini file inside the wp-admin directory, with the contents of memory=20MB.

    Is there a best practice solution on how to permanently fix this issue?

  4. *blink* 20MB?

    You should use at least 34MB. Sadly WP needs more than 20MB most of the time.

  5. mctaguma
    Member
    Posted 1 year ago #

    Hi,

    I thought that, that's why I checked! I got that solution from another post on this forum.

    I'll set it to 50MB, I'd say that will cover it at the moment?

    Cheers for your help!

    Matt

  6. zakkates
    Member
    Posted 1 year ago #

    What is the link to the other forum post that resolved this for you?

    I created a file called "php.ini" that I placed in the "wp-admin" directory. The contents of the file were simply "memory=50MB" and it did not fix my issue.

    thanks!

    zk

  7. esmi
    Forum Moderator
    Posted 1 year ago #

    @zakkates: It is impolite to interrupt another poster's ongoing thread with a question of your own and it causes significant problems for the forum's volunteers. Please post your own topic.

Topic Closed

This topic has been closed to new replies.

About this Topic