WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 500 Error after editing permalink options - help! (9 posts)

  1. sammyd56
    Member
    Posted 6 years ago #

    I am getting a 500 internal server error after I tried to edit my permalink options (and obviously messed it up!). How can I reverse what I changed when I can't get into the admin panel? Any help greatly appreciated :) :) :)

  2. IcelandDream
    Member
    Posted 6 years ago #

    Comment out the changes made to the .htaccess file in the root folder. or rename/delete the file if nothing else important is in the file. Apparently your host doesn't have mod_rewrite or there is a syntax mistake in the file.

  3. sammyd56
    Member
    Posted 6 years ago #

    Thanks very much IcelandDream. I renamed .htaccess and now I can view my blog again, however whenever I go to the Permalink settings and try to change them back to default the .htaccess file is recreated and the problem is back. The content of the file is this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Perhaps could someone let me know which file the permalink settings are stored in so I can change it back manually? Or is there another solution?

    Thanks for your time

  4. sammyd56
    Member
    Posted 6 years ago #

    Ah... and also, I just noticed that I can't access comments either as the link isn't found :( I definitely need to find out those settings and change them back. Someone please help!

  5. sammyd56
    Member
    Posted 6 years ago #

    Aha! I have figured out a solution, don't worry. For anyone else having this problem - I found that navigating to the Permalink setup page and then deleting .htaccess before clicking "Update Permalink Structure" solved the problem. Thanks again IcelandDream.

  6. rhodz
    Member
    Posted 6 years ago #

    oh! man...ive deleted my htaccess file and still not working.. can anyone assist me on this..

    im still getting this error..

    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@lagahit.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

    help!

  7. WebFadds
    Member
    Posted 6 years ago #

    Hello Rhodz & All -

    There's a potentially deeper issue here. I had the same problem, and my hosting tech. discovered that, depending on the number of URLs involved with the permalink change, changing permalinks (I'm using WP 2.5) could cause Apache to trigger a 500 Internal Server Error due to a "maximum redirects reached" setting within Apache. Your Hosting Tech. can change that for you, but I don't believe it can be done via "WHM" on a Virtual Private Server. Server needs to be restarted after the change.

    THEN: After restart, still had error, so turned off all plugins, deleted htaccess file, reinstalled WordPress (after back-up), and made sure new (blank) htaccess file was uploaded and writable (chmod). THEN... and only then... problem resolved.

    Hope this helps.

    Moderator -- I'm not sure how WordPress PHP talks to Apache... but maybe this can be addressed by the core team.

    - Scott
    WebFadds.com

  8. magicball
    Member
    Posted 6 years ago #

    Nice to read that all. But. When you get this 500 Internal Server Error and do all of the necessary changes, restore etc. and everything is working again, then some days later it happens again and you have to redo all of this. After the x-time it's like a nightmare you have over and over again. I really have no understanding for this. And I really do not understand why only a few people have this problem. Or only a few "known" people? And all the others are solving it every day at midnight again and again?

  9. crille
    Member
    Posted 6 years ago #

    I also get this 500 Internal Server Error when I changed the permalink options und manual uploaded the .htaccess-file via ftp.

    The problem was the utf-8-charset of the .htaccess-file. I convert it to ANSI and everything works fine.

Topic Closed

This topic has been closed to new replies.

About this Topic