WordPress.org

Ready to get started?Download WordPress

Forums

412 Error when trying to post an entry? (12 posts)

  1. SapphireH
    Member
    Posted 8 years ago #

    I've done quite a bit of searching for the solution to this, but none seem to apply to my situation. Being new to WP, there is probably some simple explanation. I have tried most of the fixes suggested for being blocked from commenting, etc. but none seem to help me with posting.

    If I copy/paste HTML coded text from my HTML editor to my Write wysiwyg, or to my w.bloggar program, and attempt to post it, I repeatedly get a 412 Error -
    Precondition Failed
    The precondition on the request for the URL /wp-admin/post.php evaluated to false. -

    If I attempt to post/publish from w.bloggar, I am told "412 - HTTP Post Failed. The Error Number Is The Returned HTTP Status Code."

    Near as I can tell, WP is assuming I am a spammer - to my own blog. Again, I am not attempting to post a comment, I am attempting to post an actual entry into my blog.

    I had another blog on blogger.com for a few weeks. I have about 10 posts that I am trying to copy over onto my WP blog. I did not want to import my blogger.com blog - just a couple of the posts.

    Are there are suggested solutions for how I can change settings regarding WP seeing me as a spammer?

    I have already attempted the following:
    Changing Options>Discussion settings
    Look for Blacklist in phpMyAdmin (no blacklist found, nor do I have any plugins installed for spam, etc.)
    Copy/paste HTML to Notebook then to Write or w.bloggar
    Copy/paste HTML directly from blogger.com Edit window
    Copy/paste HTML directly from "Previous Posts" feature in w.bloggar

    There are about 7 hyperlinks in the post I am attempting to make. I wonder if I am just destined to have to hand code them all again, unless someone knows a way around this?

    Thank you in advance for any insight you can offer.

  2. Try disabling all active plugins. Do you see any improvement?

  3. SapphireH
    Member
    Posted 8 years ago #

    Hi -

    I don't actually have any active plugins.

    I went through the article I was trying to post, paragraph by paragraph - posting each one at a time to see if it would go through.

    The one that wouldn't? It had the word "Gamble" in it.

    I do NOT want my posts censored by some bot on my own blog. Can anyone tell me the exact file I need to modify to review the blacklist? There is nothing listed in the blacklist under Options>Discussions nor do I have even a single plug-in installed. I only installed WP yesterday on a brand new server, so there's nothing tucked in somewhere that I forgot about. My WP has never been configured, in any way by me, to censor words.

    Thank you again!

  4. skippy
    Member
    Posted 8 years ago #

    It's quite possible that your hosting provider is using mod_security, and aggressively filtering the incoming data.

    If you have no Spam words defined, and you're not using any plugins, it's highly unlikely that this is being caused by WordPress.

  5. SapphireH
    Member
    Posted 8 years ago #

    Thanks, Skippy - any idea where I might find mod_security in my root directory or database - or should I just sort of poke around until I find it?

    Just want you all to know how much I appreciate the help. I'm learning as I go, and forums like this are just a huge help to the self-taught site owner.

  6. skippy
    Member
    Posted 8 years ago #

    mod_security is something that is enabled for the entire web server, and not for individual web sites serviced by the server. As I said, contact your hosting provider.

  7. Would you mind quoting what you attempted to post? There is a known problem when posting with words that are actually commands, like "cron" or "curl".

  8. SapphireH
    Member
    Posted 8 years ago #

    It was the word "Gamble," Macmanx - once I removed that word, the entire article posted just fine I didn't have to change/remove/edit anything else except the word "gamble.".

    Skippy, thanks - I'll contact them immediately.

  9. If it was the word, "gamble", then it is most definitly mod_security "stopping" your "spam".

  10. jfruh
    Member
    Posted 8 years ago #

    Thank god for this thread. I just had the same thing happen to me. The word that caused the problem? "Unsatisfying." Bizarre.

    jf

  11. padotj
    Member
    Posted 8 years ago #

    I was having this exact same trouble. I was posting a quick shell script and got the error over the "lynx." That sucks man!
    JOEY

  12. drobbins
    Member
    Posted 8 years ago #

    I had a similar problem, with similar error codes from w.bloggar. Try renaming your xmlrpc.php file, making sure you also change the settings in w.bloggar to point directly to the newly named file - so, if was previously /root/wordpress/ or root/wordpress/xmlrpc.php, change it to root/wordpress/newfilename.php
    Apparently on some systems/servers mod_security blocks thh file, so try renaming it to see if that is it.

Topic Closed

This topic has been closed to new replies.

About this Topic