WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404s on everything except the front page (5 posts)

  1. ruthieontheroad
    Member
    Posted 4 years ago #

    Hello - I just installed WordPress a few hours ago, and everything was working fine for a while (I didn't check blog entry pages, but static pages were working). Now, suddenly, my static pages and individual blog entry pages are bringing up 404s. Example:

    http://ruthieontheroad.com/ - works fine
    http://ruthieontheroad.com/about/ - static page broken
    http://ruthieontheroad.com/2009/10/05/news/ - blog entry page broken

    Can anybody help?

  2. s_ha_dum
    Member
    Posted 4 years ago #

    What does your .htaccess look like?

    Do you have mod_rewrite enabled on your server?

  3. ruthieontheroad
    Member
    Posted 4 years ago #

    Solved by @apljdi in another thread - ta muchly.

    Just in case any other non-techy person finds this (like I tried to do, when searching past threads trying to solve this issue) my issue was that the permissions on my .htaccess file (in the very top folder of my site) were wrong. WordPress told me this every time I tried to change my permalink settings, but the message was at the bottom of the page so I missed it.

    I used my FTP client to download the file, opened it in Notepad, pasted the code given to me by WordPress into it (overwriting everything that was there previously) and re-uploaded it. Fixed.

    Thanks for your excellent help, @apljdi.

  4. Peter Chester
    Modern Tribe
    Posted 4 years ago #

    what thread was this solved on?

  5. s_ha_dum
    Member
    Posted 4 years ago #

    I think ruthieontheroad means this thread-- A NEWBs Heads Up on the Permalinks-- though attributing the solution to me might be overly generous.

Topic Closed

This topic has been closed to new replies.

About this Topic