WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] 404s on Every Page (11 posts)

  1. Nerdist
    Member
    Posted 5 years ago #

    Hey all-

    For some reason every page link on my site (nerdist.com) is returning a 404. The home page shows up, but that's it. I've disabled all plug-ins and made sure that the database is still intact...it's just not connecting to the files there for some reason. Any thoughts?

    thanks!

  2. thisisedie
    Member
    Posted 5 years ago #

    Did you change the permalink structure? Who's your host? Did you mess with the .htaccess file? Try resaving the permalinks and see if that fixes it.

  3. Shane G
    Member
    Posted 5 years ago #

    Hi,

    Please correct the permalink structure and also check for rewrite rules in .htaccess file....and I recommand you to change the permissions for your blogs .htaccess file to 644.

    Thanks,

    Shane G.

  4. Nerdist
    Member
    Posted 5 years ago #

    Thanks for the response!

    I did not mess with the .htaccess file. Here it is:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    What should it look like? I did just resave the permalink structure but it didn't seem to change anything. Not sure how to change the permissions to 644.

    hosting company is Hostway.

  5. isaacwedin
    Member
    Posted 5 years ago #

    You might want to revert to the default permalink setup (http://nerdist.com/?p=1 style) so the site's not broken while you're getting it figured out.

  6. doesnotvalidate
    Member
    Posted 5 years ago #

    Hi Chris,
    This is most likely something wrong with your mod_rewrite setup. Try to attack it logically... Was it working and then it just quit working for some reason? Were you in there messing with stuff today?

    What version of WP are you using? Have you tried upgrading?

    I would do this:
    1.Disable all plugins
    2. Remove any custom permalink changes you've made so we're back to using querystrings and such.
    3. switch back to the Kubrick theme

    If you try it then and you're still having problems - something is wrong, and I would recommend a reinstall of the WP core and a repair of the database.

    If things start to work, then just enable things one by one until you figure out what's causing it.

    If you need more help than that - hit me up:
    Dane Hesseldahl
    dane@doesnotvalidate.com
    http://doesnotvalidate.com

  7. Puck
    Member
    Posted 5 years ago #

    Hey nerdist, saw the call from @wilw to help you in Twitter and the 140 limit is hurting for this kind of thing.

    That's the proper .htaccess but your site still isn't rewriting. My guess is mod_rewrite is broken or not compiled. It's possible your host forgot to include it in a recent rebuild of Apache.

    If you create a php file with this in it:

    <head>
    <title>PHP Info</title>
    </head>
    <body>
    <?php phpinfo(); ?>
    </body></html>

    upload that (as phpinfo.php) to your site's root and then browse to it you can look to see if mod_rewrite is there under "Loaded Modules" in the apache section.

    If it's in there then it should be working and your host has something seriously messed up somewhere.

    - @joefulgham on twitter

  8. bartmoss
    Member
    Posted 5 years ago #

    The .htaccess is correct. Since urls like http://www.nerdist.com/?p=300 redirect correctly, and the beautified URL then results in an apache default 404, my guess is that your mod_rewrite is broken / deactivated. Check with your provider to see whether there were any changes.

    Isaac's workaround is of course a good idea to follow until you found the problem.

  9. mmayers
    Member
    Posted 5 years ago #

    Is it possible that use of mod_rewrite in .htaccess files was disabled in Apache... somehow? You need at least AllowOverride FileInfo for mod_rewrite to work inside .htaccess files.

    See: http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

  10. Nerdist
    Member
    Posted 5 years ago #

    Thanks all. Currently on hold with Hostway.

    Here's the php info page:
    http://www.nerdist.com/phpinfo.php

    Doesn't look like mod_rewrite is in there.

  11. Nerdist
    Member
    Posted 5 years ago #

    I guess Hostway must've resolved it. I sure as hell didn't do anything! Thanks for all of your help, everyone!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags