WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
404/410 errors when minifying activated (6 posts)

  1. petrich
    Member
    Posted 1 year ago #

    Hello there,

    Thanks for the job : this plugin is great...

    I am facing something strange on WordPress 3.5.1, WT3C 0.9.2.9, on IIS 7.5 web server and PHP 5.4.12

    As soon as I activate minify, I get 404/410 errors like the following:
    The following requests are returning 404/410 responses. Either fix the broken links, or remove the references to the non-existent resources.
    http://www.keepintouchwithus.com/%5Cworldtour/wp-content/cache/minify/000000/9fb88/default.include.d088a4.css

    Indeed, I can't find any css file in the directory so I guess It s actually notre created.

    Anyway, If someone has faced same issue, I woudl be glad to learn from him.

    Thank you very much
    Website: http://www.keepintouchwithus.com

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. petrich
    Member
    Posted 1 year ago #

    Hi there,

    Trying o change cache method from Wincache to Disk : basic, now, I get minified fils in the cache/minify directory: that's somehow better !

    But, I still get the 404/410 error and it seems to be due to '%5C' which is added in the URL of the minified file:
    http://www.keepintouchwithus.com/%5Cworldtour/wp-content/cache/minify/000000/9fb88/default.include.d088a4.css

    It might be a misinterpretation of path because of the file system used on my Web server (IIS, Windows)

    Pretty sure that this can be handled by a rewrite rule in the wb.config (equivalent of Apache .htaccess file) but I can't figure out what rule I would have to implement.

    If Frederick or anyone else could give a piece of advice, that 'd be cool :-)

    Thanks

  3. petrich
    Member
    Posted 1 year ago #

    I am still facing issue on this. I sent a bug submission from support Tab in W3TC

    Anyone has faced the same ?

    It seems that there is a double forward slash in that built URL path for the minified scripts inluded in the <head> of my theme.
    That's what generates a 404 error.

    Thanks

  4. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    It's not a common issue. I think I've received your submission.

  5. petrich
    Member
    Posted 1 year ago #

    OK Fred, yes you probably received my submission with credentials for you to troubleshoot this.

    I was just trying to figure out where you build the URI for the minified .js and .css files when minify is enabled ... BUT the complexity of W3TC 'tree architecture' doesn't allow me to identify this.

    Anyway if I can hep you with something, please feel free to ask ...

    Thanks

  6. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    Yes, I did. Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic